Nalin or Plymouth, Help with Jtag


Bronze Member
Username: Ed_fitz


Post Number: 16
Registered: Nov-07
Nalin or Plymouth,
Please help.

I received my Jtag cable today but when I connect the box and the computer I have the following problems. This cable came with the ability to connect two double AA batteries.

Should I load two batteries or just ignore the batteries?

When I open the Wall V 2[1] 2 program I receive this message "Could not acquire I/O. Windows NT/2K users must have administrative rights".

When I start Skymax --up 12.04.2005 program I receive this message on the screen:

Init jtag
ID code 00000000
Fail Deu, Please restart or reset CPU box.

When I start the Jkeys by D2 I receive this error. "Error Com1 does not exist"

Do you know the number of the chip in the Multistar MS2500PF? Mine is covered with a large heat sink and I cannot find the number. Might it be a 29L800BTC?

My computer is operating with Windows XP. Are there any changes I should first make to my computer so it will recognize the cable to the printer port? My regular printer is connected via a UBS cable.

Any help would be appreciated.

Gold Member
Username: Dimwitt

Post Number: 1058
Registered: Aug-06
Wall - right click on the application
, select properties and compatibility
- change compatibility mode to Windows 98/me

Jkeys - run jkeys (ok to comm 1), click file and preferences and change interface to parallel port

Bronze Member
Username: Ed_fitz


Post Number: 17
Registered: Nov-07
Hi Tooter,

Thanks for responding and providing help.
I changed the Wall Windows 98/Me.
I changed the Jkeys preferences to Parallel Port.

Then I opened the Wall and received a "Warning the ID code is incorrect". I exited this warning and the program remained on the screen. I then pressed "Reset up" and again received the same warning. Again I exited it and the following is what was on the screen.

The "Serial number" reads R0000000000
The "Box Key" reads 00
The "Flash Base address" reads 1FC00000
The "Length Hex reads 200000
The "Address offset" reads 0
The "Jtag Delay" reads 0

On the right side of the Wall screen there are a few choices.
1 "Reset Up", 2 "Reset EJTAG", 3 "Refresh Items" and 4 "Select". When I press "Select" it is looking for what I assume is the latest Jtag bin which I have.

When I opened the Jkeys I had the following:
The "Device ID" reads 0X1D405041
The Device reads Sti5518MVB-X
In the "IRD Model" I had "Unknown"

I then clicked on the drop down menu and I had 6 choices as follows:
1 Pansat 2500-2300, 2 Pansat 2700A, 3 Pansat 3500S, 4 Brute force 1MB and 5 Brute Force 2MB. Should I select the "Brute Force 2MB from this menu?

When I opened it again I did not receive the ID number or Device number but after a few tries I did receive the numbers back on the screen.

On the right side of the Jkeys screen there is a "Save Memory" section and the following are what was in each area:

The "Region" reads "User Specified" and the drop down gives no other choice.
The "Start" reads 7FF80000
The "Bytes" reads 80000
The "Width" reads 16 Bits and the drop down gives a choice of 8,16,32. Which is the correct setting here?
The "Delta" reads 2 and the drop down also give a choice of 4. What should the "Delta" be set to?
The "Offset" reads 0

I have a choice of four buttons on the right of the screen.
1 "Save Menu", 2 "Flash Programming", 3 "EEProm Programming" and 4 "Development Panel".

When I click on "Tools" I have a choice of "Port Diagnostics" and "Passive Trap/DCU".
Under "Port Diagnostics" I see the LPT address OX378.
There is a heading on the left side "Data Bits Out" and no boxes are checked. Should any of them have a check mark or should I leave them blank?

I have asked a number of questions about both programs and hope you will be kind enough to help me with some answers. Thank you.

Gold Member
Username: Runnerguy


Post Number: 1737
Registered: Sep-06
Ed,,Go to DSSTESTER DOT COM and use their search engine for your answers.

Gold Member
Username: Dimwitt

Post Number: 1059
Registered: Aug-06
Wall - all you do is open , click ok to wrong ID and select refresh items then let it run in the background.

Jkeys - after it detects the device (Sti5518MVB-X )you should be able to select flash programming - then you would erase the chip and write to it.

Basic guide

Bronze Member
Username: Ed_fitz


Post Number: 18
Registered: Nov-07
Hi Zulu and Tooter

Thank you for your suggestion. I now have some more info but am still not able to proceed with the Jtag operation.

The Skymax 2.2 and 1.1 give me the same error message "Fail DCU, please reset or reset CPU box".
Do you know how to get rid of this message?

When I open the Wall I receive a number of different pieces of information when I press the "Refresh Items" button.

For example: I receive 7 different ID numbers, Implementation Numbers, Serial Numbers, and Box Key numbers.

The Flash Base numbers do not change as all the other numbers change. They are IFC 00000, Length Hex 200000, Off set Hex 0.

It appears that the Skymax might be the simplest program but I am unable to go past the error message. "Fail DCU, please reset or reset CPU box".

Also the Jkeys program will not obtain the Device ID or the Device. I have set it to Windows 98/me. It did obtain them a few days ago. I changed no settings.

In Jkeys by D2 under "Tools", should I do anything to the Ports Diagnostics which are now all blank?

Thank you for any help you can provide also to anyone else.

Gold Member
Username: Runnerguy


Post Number: 1741
Registered: Sep-06
Here are about 20 possible solutions: D&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

connections should be checked first
« Previous Thread Next Thread »

Main Forums

Today's Posts

Forum Help

Follow Us