Emerson (Funai) LC320EMXF (Starting issues/Looks like Skittles)


New member
Username: Cjhazdroid

Post Number: 1
Registered: Sep-11
Brand: Emerson (Funai)
Model: LC320EMXF
Manufactured: September 2009 J
Power: 120V~60 Hz 155W
Description: 32" 720p LCD HDTV
Ports: 3 HDMI, 1 component, audio out, digital audio out coaxial, 1 antenna in, 1 RCA YRW, 1 s-video, and a service terminal

How I got here:
My TV has worked flawlessly since the day I bought it. I have two almost identical televisions. I own and have fully read and studied the service manual, schematics, and user guide for this television. When attempting to place my other TV into service mode via the hidden button behind the remote control faceplate/sticker, I also placed the second TV into service mode. As I understand, my son was watching the DVR and had pressed 'info' on the other remote. The screen then began flashing multiple colors -- red, then green, then blue, then white, then black, then shaded from top to bottom black to white, then shaded from left to right black to white, then repeating the entire sequence without delay. When I unplug the device and plug it back in, it turns on normaly, displays "Digital television" (as normal) and then returns to the same issue. Remembering that I had read something about this procedure, I quickly skimmed through the manual and reread the following excerpt:

Quote from the service manual:
1. Turn the power on.
2. To enter the service mode, press the service button- then [POWER] button .
3. Press [INFO] button unit to initialize the LCD television.
4. "INITIALIZED" will appear in the upper right of the screen. "INITIALIZED" color will change to green from red when initializing is complete.

Maybe the screen is stuck in initialization mode, or maybe I don't know what I am talking about and it is something different entirely. The television does not respond to any commands from the remote (the 'POWER' button should exit this as far as I understood) or on the TV.

Note: "INITIALIZED" is never displayed

Things I have tried:
Pushed every button on the TV and remote control

Verified my remote is working (for some reason a couple buttons work to control my Eden Pure heater)

Unplugged it for 4 hours and then plugged it back in.

Swore at it.

Things that I have:
A multi-meter with AC/DC/Ohms/diode testing abilities

A giant illuminated desk mounted magnifing glass

A soldering iron with experience soldering surface mounted components

Service manual with included schematics and parts list

Grounding wrist strap

Ability to identify dangerous HV components (EX: capacitors) and safely discharge them

A temper

Is there any hope for this device?
Thank you for your advice.

Gold Member
Username: Magfan


Post Number: 2584
Registered: Oct-07
find out how to do a Hard Reset?

New member
Username: Cjhazdroid

Post Number: 2
Registered: Sep-11
I don't mean to sound detrimental, but I did state I unplugged it for four hours. That should have been enough time for a hard reset to take place. However, it wasn't. This issue has been resolved. On the remote control if you depress and release in sequence up, down, power it escapes this mode.
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message


Shop Related Deals


Main Forums

Today's Posts

Forum Help

Follow Us