Toshiba player won't play some DVDs


New member
Username: Rastaholden

Post Number: 1
Registered: Apr-06
I've recently been experiencing problems where some disks will not play on my Toshiba SD-5960. It has happened on three movies - Transporter 2, Sky High, and Flightplan - all rented through Netflix. I know the problem isn't with the disks, because all of these worked on an older (and cheaper) Phillips player.

The Play symbol initially displayed on both Sky High and Flightplan, but stopped immediately. On Transporter 2, all credits played and after selecting "Play" the Federal warning displayed and the disk stopped playing. After this the player appears to lock up - I cannot hit play, skip, menu, etc. I have to turn the power off and try again (of course to no avail).

Does anybody have any ideas?

While looking into this, I have found out that I can return the SD-5960 to Toshiba because of the HDMI quality. Does anybody know if they exhange this for a 5970 or 5980 or refund the purchase price?

Gold Member
Username: Samijubal

Post Number: 2525
Registered: Jul-04
Have you tried cleaning the discs? Some players are more picky than others. I use Plexus on all rental discs before I play them. You can get it at motorcycle shops, the best stuff made for cleaning discs.

New member
Username: Rastaholden

Post Number: 2
Registered: Apr-06
It's definitely not the disc. The disc I'm currently having the problem with is Transporter 2 and it's a double sided. Both sides stop in the exact same spot - on the Federal warning.
« Previous Thread Next Thread »

Main Forums

Today's Posts

Forum Help

Follow Us