Like

LG DLP component video input not working

 

New member
Username: Kevincp

Post Number: 1
Registered: Aug-12
I have a LG RU-44SZ63D DLP set that is getting no component video signal. There is signal from the coax TV input, S-video and composite video inputs.

(BTW, I think we may have had a power surge, as my pc power supply is fried and our Wii suddenly doesn't put out a video signal either)

Someone suggested that I needed a new digital board, but I pulled up schematics and there is a separate component video board, so isn't it more likely the component board is bad? The block diagram shows both the component board signal and the tuner board going to the digital board, so if the digital board was bad wouldn't all the video be out?
 

Gold Member
Username: Magfan

USA

Post Number: 2851
Registered: Oct-07
Depending on where you live, get a WHOLE HOUSE surge protector installed.
Also, use point of use surge protection especially if whole house is not an option.
If it was a power glitch, you're into it for far more than the cost of even a couple GOOD (not 30$) surge protectors. For the stereo / video end of things, invest in one...200$ worth of Panamax and we wouldn't be having this chat. better sound and picture, too.

Try cross checking the WII on another TV, perhaps. Maybe it's not fried, just the input board on the TV?
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message
   

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us