Vizio VW37L picture/backlight problem


New member
Username: Pbfoot

Post Number: 1
Registered: Oct-11
I have a 37" Vizio LCD that is several years old. There are two issues I'm having that may or may not be related.
When I try to turn the backlight down below 25, the screen flickers a couple seconds then goes dark. I can tell the screen is getting power, just the picture is gone, only audio. I cupped my hands over the screen and my eyes and cannot see anything.
Since I did not hit the OK button, I can turn the TV off then back on and the picture is back.
The other issue is the picture itself, see attached photos. See how the lighter areas of people's skin doesn't transition from light to dark good? If I watch something with solid colors, like Family Guy, there are alot of artifacts in the white and red hues, and a little in the blues.
Is this most likely a problem with the backlight inverter or the main board? Or both?
Thanks for the assistance.

New member
Username: Ram_rod

Fayetteville, Arkansas

Post Number: 3
Registered: Oct-11
More than likely it's neither one if your model has a T-Con board. When the inverter goes bad you'll have no picture at all. That's just my experience with the Vizios

New member
Username: Pbfoot

Post Number: 2
Registered: Oct-11
Thanks for the response. I'm on the hunt for a t-con board!

Top Deals

Loading, please wait...
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message



Main Forums

Today's Posts

Top Deals

Forum Help

Follow Us