Samsung 56" DLP


New member
Username: Js6605

Post Number: 1
Registered: Mar-10
I bought this tv about 3 yrs ago model number HLS5686W and model code HL85686WX/XAA. When I first bought it everything would work fine. Until I had to use the HD. Once the HD was on it would stay on for about 30 minutes and then make a buzzing noise the screen would shut off, but the audio would still work and all 3 lights would blink. I eventually took it apart and tried to blow everything off thinking it might have been dust buildup. When I put it back together and went to turn it on it now just turns on for a second then shuts off. Still has buzzing noise and three lights blinking. Any ideas what could be the problem, and an idea of what the cost could be. Wondering if its even worth holding on to.

New member
Username: Clef77

Post Number: 2
Registered: Apr-10
This sounds like the usual lamp overheating issue. It needs to be replaced. Be aware that all you need to do is replace the actual lamp. Many people buy the housing the lamp goes into thinking they aren't reusable. Some websites offer actual video of how to go about replacing the lamp. I think the OEM manufacturers are either Osram or Philips. You can expect to spend around $90-130, pending on the specifics your TV requires.

Best of Luck,


Top Deals

Loading, please wait...
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message



Main Forums

Today's Posts

Top Deals

Forum Help

Follow Us