Red cloud and blue cloud


New member
Username: Jmont1967

Post Number: 1
Registered: Sep-06
I need help with my Hitachi 50v500. I've had for 18 months and it's been nothing but problems. I don't have warranty on it. I know that was very stupid. I have 180hrs viewed. The first problem was the lamp that burned within a few month. Now I have the common reddish/pinkish cloud that appears when the tv is dark. I also have a new problem now. there's a blue cloud in the middle of the screen. I'm ready to dump this thing. I tried going into the menu, but I don't know where to start exactly. The menu is consisted of 3 different areas. The 1st one is Adjust mode, then there's is the HFREG/N,and then there's the Sub Bright area. I need exact instructions. If any one has the manual or can show me on this forum, I will forever be grateful.

New member
Username: Mikey48

Port Orchard, WA

Post Number: 1
Registered: Jul-07
Sounds like your light engine is toast. It is a known problem and Hitachi knows about it. Many people out of warranty have got them to provide the replacement if they pay for the labor to replace it. The labor runs from $250 to $400. I now have the same problem on my set. You can buy the replacement online for about $400 if you do the labor. The replacement part # is UX22201Dr and is a rebuilt, just google the part number and you will find it. Google 50V500 to see all the forums that discuss the problem.

New member
Username: Rbm10010

Post Number: 1
Registered: Dec-07
I found the Hitachi UX22201DR Light Engine on Hope this helps!

Bronze Member
Username: Imjross


Post Number: 41
Registered: Aug-07
Hitachi customer service WILL assist in the cost of the repair.
Contact Hitachi customer service for an Authorized servicer in your area.
I do NOT think an optical light engine is something a customer should replace.

Top Deals

Loading, please wait...
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message



Main Forums

Today's Posts

Top Deals

Forum Help

Follow Us