Like

QUESTIONS FOR NAD T7xx SERIES OWNERS

 

Paolo
Unregistered guest
Hello guys,

for those of you owning a NAD T752, would you please be so kind to answer to the following question:

Do you hear a loud "bump" in your speakers if you switch the unit off from the front panel switch WITHOUT putting the unit in stand-by first through the remote?

My T752 worked flawlessly for two years (purchased in April 2003) and then developed few annoying quirks:

- Occasionally a white bar would appear overimposed to the video image, scrolling slowly and repeatedly from bottom to top of the screen.
- While using the OSD the unit would freeze and not respond to any commands. Only thing I could do was to switch it off from the front panel switch
- The unit would also freeze occasionally if I left it on (fully on, not stand-by) without input signals. Again, only thing I could do was to switch if off through the front panel power switch.
- The front panel display showed corrupted text messages (i.e. "RENTER" instead of "CENTER" when displaying the channel levels, or "/RONT LEFT", instead of "FRONT LEFT")
- And finally, once in a while I would get the "bump" in the speakers when switching the unit off from the front panel switch.

Few weeks at the local NAD service center took care of everything but the "bump" at switch off. I just called the service center and talked to the technician who repaired the T752, and here is the scoop:

He said the bump is normal, he has seen other NAD receivers do it....... He implied that the proper shut down procedure is to put the receiver in stand-by first and THEN use the mechanical front panel switch.
He claimed that taking the receiver back to service wouldn't help it, because there is nothing he can do to fix the "problem". He said that the muting circuit is powered off too quickly to do its stuff when switching the unit off through the main power switch.

He might be the NAD authorized service technician, but I don't buy it, for a number of reasons:

- For two years I have been routinely switching it off from the front panel switch without going through stand-by first. NEVER heard any "bump" before the unit developed all the other issues I mentioned.
- The "bump" is REALLY loud. I think it may even damage the speakers in the long run. NAD would be a fool in not putting a warning on their manual, and there is none that I have seen.
- Besides, virtually all receivers these days have a stand-by and a full OFF mode. I can't believe something as normal and trivial as powering down requires this kind of precautions. Does a Denon, Yamaha, HK, Marantz, Rotel, Integra, Pioneer, Onkyo or even any of the other NAD T7xx required the same "care"????????
- I still have my old TEAC Dolby Surround receiver (which I re-instated while waiting for the NAD to be repaired). And yes, you have guessed it right, I can switch it off however I like and there is no "bump"......
- I have an engineering background. If something like this is really "normal", in my book that's called poor engineering. NAD can implement a Soft Clipping circuit, a Dual Rail Power Supply, a simultaenous, continuous rated power 5.1 receiver and NOT an anti-bump circuit? Give me a break.....

I'm going to talk to NAD directly about this, and I may even pay a visit to them (I live in Massachusetts, where they have their N.A. HQ)
I didn't buy one of their products to be fed this @%#$*&%

Too bad, really. Other than this "incident" I have been very happy with the performance, both with movies and music. The dealer has been top class in make me audition the receiver several times before buying and extremely cooperative in facilitating the repair.
The service center fixed everything else and even upgraded the firmware to the latest version (1.22) without me asking.

My apologies for the long rant and PLEASE do not turn this request of mine in another NAD bashing. I know some people can't stand them because of their quality and realiability issues, true or perceived.
The purpose of this long posting is:

1. Verify if other T752 owners have the "bump" issue
2. For the benefit of the forum readers I wanted to give some details of the other issues my T752 had.

Thanks in advance, Paolo.

 

New member
Username: Gualter

Post Number: 4
Registered: Apr-05
I have T752 and I don't hear any loud "bump". when I turn it off in front panel, I hear a "click" when the volume is loud, nothing more, and is normal in amp.
Althouth, I hear a little "hiss" when I put the hear in front the speaker. And I have nothing to do with it.
 

Silver Member
Username: Johnny

Missouri

Post Number: 541
Registered: Dec-03
I haven't owned that many amps, so I don't know if it is "normal" or not, but my NAD T762 does exhibit this "bump" that you describe. There are a few ways to keep it from happening. One way is to be sure to turn the volume all the way down before you turn off the receiver. This is probably a good idea anyway, to avoid turning on the receiver when the volume is up too loud and damaging your speakers. The other way to avoid it is to do as the NAD technician said and do a "soft" power off with the remote and then use the front button. I am kind of wondering though why you would need to use the button on the front of the receiver at all? I keep mine in standby 100% of the time. I don't think I have ever used the "hard" power off button in almost two years of owning the unit. It just seems like using the remote is much easier. If you must use the button on the front of the machine, try doing as I said and turn the volume all the way down before turning the power off.
 

New member
Username: Gualter

Post Number: 5
Registered: Apr-05
Johnny,
Many times, I leave it in standby. that's why the receivers T753, T763 and T773 has the button in back.
The NAD works better with it in standby.
 

Paolo
Unregistered guest
Gualter & Johnny,

thanks for taking the time to respond to my post. I did notice that turning the volume all the way down prevents the "bump" or "pop" noise. And of course there is no issue at all if I never use the front panel switch and turn the T752 on and off from the remote.

I could easily live with either solution, (after all the repair took care of the other more serious issues), if my T752 had behaved that way from day one. But it didn't for basically two years and even now it doesn't do it every time I turn it off. It happens about 6 or 7 times out of 10. This is what it is driving me nuts. Call me a perfectionist or obsessed with details, but if I could turn off the T752 any way I liked for two years, I don't see why an authorized NAD Service Center shouldn't be able to bring it back how it was.

Besides, another scary thing I noticed is that every time I hear the "bump" noise I also see one or two segments or icons on the display flashing for a moment at an intensity much higher then normal before the display goes blank. What if this stresses the VFD display and in a couple of months it goes dead?

Until I don't get this resolved with NAD Service I'm certainly leaving the T752 in stand-by or shutting it down after. However, I have little kids at home and the green power button it too much of an attraction... I would feel much better if the issue would be resolved.

It is interesting that NAD decided to move the power switch to the back of the new units. However, I still believe that a company with engineering capabilities such as theirs shouldn't have to make a user worry about the "proper" power down sequence.

Thanks again for your replies and keep enjoying your NADs. The sound is surely great, I have always loved the NAD sound.

Take care, Paolo.
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us