Like

Smell burning AMPLIFIER help me pleasE!

 

New member
Username: Hero_honda

Post Number: 1
Registered: Feb-05
HELP ME PLEASE!!!

There is a power shock in my home when i was listening to my music. When my power is back, i turn on my amplifier and i can smell bit of burning inside my amp.. i quickly shut my amp. When i turn on my amp, the power led is on but when i play music... i can;t hear anything.. What is being burned? Im using audiolab 8000A stero amplifier.. I was told this amp for power protection.. what the hell is going on? What to repair normaiillly and how much it cost to repair?
 

Bronze Member
Username: Tevo

Chicago, IL USA

Post Number: 62
Registered: Feb-05
Sorry to be the bearer of bad news but it sounds like the surge fried your amp.
Are you using a high quality surge protector for all your sensitive equipment (i.e., your stereo components)?

Contact the manufacturer for information on repair. They should be able to tell you the details and the cost.

Good luck.
 

New member
Username: Hero_honda

Post Number: 3
Registered: Feb-05
the thing is my amp power led is on but it cant work..... so frustrating!
 

New member
Username: Hero_honda

Post Number: 4
Registered: Feb-05
Here is a link to show u.. u need to save it and use the magnifiying glass to see my drawings.

no1: it is burned ... that small tiny thing .. i dont know what u called it... its like a fat needle or someything.....


http://yakuzaer.bravehost.com/audiolab1.jpg
 

Unregistered guest
Can anyone help me with my amp troubles? Just recently the right channel on my amp has caused the speaker to crackle and this is regardless of music being on or not.I know its not the speaker so therefore it must be the amp PLEASE HELP!!!
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us