Like

Technics AV Control Receiver SA-DA 20

 

New member
Username: Zepped

Post Number: 1
Registered: Feb-08
HELP! Turned on, got OVERLOAD, turned off. Tried again, OVERLOAD. Checked ALL wiring and connections..GOOD ORDER. Tried again, OVERLOAD. Turned off power. Again. OVERLOAD....disconnected ALL wires, etc. Pulled plug, left overnight. Powered back up...still showing OVERLOAD ???? There is NOTHING connected to reciever now, and STILL getting OVERLOAD. I have even RESET it, and STILL getting OVERLOAD! Anyone out there tell me what I am doing wrong? Always worked. Last time I turned off. Sound was NOT loud, just listening to the radio. Been doing the same thing for the past 3 years. NEVER have had any trouble with it. SO FRUSTRATED! PLEASE HELP!!!
 

New member
Username: Biuta

Post Number: 1
Registered: Mar-08
I am having the same issue. Have you figured out anything?
 

Bronze Member
Username: Fuji905

On Canada

Post Number: 57
Registered: Feb-07
Have the same issue with my SA-DA10, did all of the frustrating trials to no avail. Finally brought it into the shop and it was very simple. The high heat of these receivers and subsequent cooling causes the solder crack or come loose creating the obvious bad connection and cause them to heat up. The fan won't come on until put into the 1:00 position (on my receiver) as it is only triggered by current and not heat therefore allowing the unit to overheat, shutting down your unit. Cost me $90 to fix.
 

Platinum Member
Username: Nuck

Post Number: 10244
Registered: Dec-04
No protection for overheating is a bad thing, but not unexpected at the price.
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us