Technics SU-Z55 Dead?


New member
Username: Lstar24

Post Number: 1
Registered: Apr-06
Hi all, I've just got a Technics SU-Z55 Intergrated Amplifier from the car boot... and surprise, surprise it doesn't work! I'm not too bothered as it only cost a tenner for that and some nice Technics speakers.

Would be nice to get it working though. When I plug it in I just get nothing, it appears to have a nice display on the front but nothing lights up. I've tried replacing the fuse in the plug and in the amp, but neither seem to have worked. Anything else I can try? or is it destined for amplifier graveyard?

Thanks for any advice or help,


Gold Member
Username: Jan_b_vigne

Dallas, TX

Post Number: 8124
Registered: May-04

Unless you feel like spending some money, probably at least $100, to repair this amp, it's is a candidate for "best amp I ever owned but never listened to". Do not misunderstand the term "best" here. This is not a very good amp in the first place.


New member
Username: Lstar24

Post Number: 2
Registered: Apr-06
Ah ok! Thanks very much. You never know what you can get at the car boot... I recently got a pair of vintage Wharefedale RS/DD Super 12 for £12 which I've seen sell on eBay for about £150. Not bad!
Thanks for your help.
« Previous Thread Next Thread »

Main Forums

Today's Posts

Forum Help

Follow Us