Need help getting my amp to work (Technics SUV-4k)


New member
Username: Michel

Post Number: 1
Registered: Sep-05
Hello out there,

I have a problem getting my integrated amp Technics Integrated DC Amplifier SU-V4K to work. Here's what I am trying to do:

- I have 2 Technics turntables SL-1210MK2 and a mixer, which I want to connect to the amp. Sounds simple, right? Just plug the mixer master output into the amp's AUX input, set the amp to AUX and then pump up the volume... of course put a record on too ;-).

Well, as it turns out, it is not as simple as I thought it would be. The amp doesn't do a thing. Not even the headset is working. So, there must be a problem between the mixer and the amp. I tried another amp just to check, and it worked. So, the mixer and the turntables are o.k. (the amp I used to check is not an integrated map, though).

Can someone tell me what I am doing wrong? Do I have to connect a mixer to an integrated amp differently from connecting it to a 'regular' amp? Maybe my new amp is broken..., which I don't hope. The seller said that it is working.

Any help is greatly appreciated since I want to listen to my 12", and loundly...

Thanks in advance,


Gold Member
Username: Jan_b_vigne

Dallas, TX

Post Number: 5437
Registered: May-04

Try a different input and check that there is no mute function or tape loop engaged.


New member
Username: Michel

Post Number: 2
Registered: Sep-05
Hi -- thanks for the advice. I plugged the turntables directly into the phone input of the amp. Still no sound. Didn't see any mute functions engaged. How can I check if there's a tape loop engaged? I have no tape hooked up. -- Thanks, Michel.
« Previous Thread Next Thread »

Main Forums

Today's Posts

Forum Help

Follow Us