Creative Decoder DDTS-100 - help needed


Unregistered guest

I recently got a Creative Decoder DDTS-100, I was hoping to set it up with my 6.1 creative speakers via my Audigy 2 ZS (non-digital).

I've got all three analog wires going into the decoder, then the soundcard, and also a coaxial wire going form he digital out on my soundcard to the decoder.

It picks up the coaxial connection but I cant switch to any other modes - so I dont know when or even if its ever using a digital signal.

Does anyone else have one and if so could you help me out with a few hints and tips as to how to get it working?

A huge thanks for anyone that can help with this.

If you need to know anything else about the problem specifically just ask.

Thanks again.

Ezekiel Q. Cranberry
Unregistered guest
Not sure if this will help you out...but it sounds like you're a bit confused from your post (My apologies if I'm wrong about this). If you say "it picks up the coaxial connection" that would imply that the DDTS-100 is using the digital signal from your computer.

I'm not sure what you mean when you say you've got "all three analog wires going into the decoder, then the sound card" -- if you're connecting the digital out of the sound card into the decoder, you should no longer need to connect the analog lines of the sound card to anything.

I've just started looking into this decoder myself as a possible future purchase, and from what I can see, there is the main decoder box, and an external switch box. I think the external switch box is for use if you have a computer without a coaxial/optical digital out. Then you'd plug your assorted electronics (dvd player, etc) into the main decoder box, plug its analog output into the switch box, plug your computer's analog output into the switch box, and plug your speakers into the output of the switch box. Then, the switch box would be switching between the output of the decoder and the output of the computer for what gets sent to the speakers. But, if you've got a coaxial wire from the digital out of your soundcard, you should not need the switch box at all (unless you've got some other source that spits out 3 analog wires for 5.1/6.1/7.1 sound).

I'm not sure what you mean by the "(non-digital)" after naming your soundcard as from what I can tell the Audigy2 ZS is digital...perhaps you meant the speakers were non-digital...then if so I think what I've said above is all correct.

New member
Username: Ddtsuser


Post Number: 1
Registered: Oct-05
So I got this decoder and tried to connect it to my Speakers Giga Works S750 and NOTHING was going right.
I mean that - I put the COAXIAL cable (black with RCA-to mono) into DIGITAL out of the Audigy 2 ZS and when I'm try-out to HEAR something like DECODING of DTS or Dolby EX - nothing.And I CAN NOT select any of the modes like DD and DD EX...its just dosen't switch them.I DON'T KNOW WHAT IS WRONG WITH IT.MAYBE I have to adjust some of the sound card's settings maybe?PLEASE TELL ME WHAT THE HELL I HAVE TO DO to make it WORKS.And Also when I put a DVD with DTS SOUND and select it I don't have any sound...but IT IS SUPPOSED TO be there...PLEASE tell me how it should work.THANKS

Unregistered guest
I had the same problems as you all. finally after frustration, i found the answer.

none of it is in the manuals that i found.

read the following link - the best helpful part is at the bottom of my message, courtesy of Webjammin

1) Buy 6' Audio and Digital-Camera Cable (mono) from Radio Shack. Part No. 42-2444A. One end of this cable is RCA. The other end is 1/8" (3.5mm) mono mini jack.

2) Configure Sampling Rate:
- "Start -> All Programs -> Creative -> Sound Blaster Audigy 2 ZS -> Creative AudioHQ"
- Select the "Sampling Rate" tab
- Select 48 KHz
- Note: 96 KHz did not work for me. No sound.

3) Configure SPDIF Passthrough:
- "Start -> All Programs -> Creative -> Sound Blaster Audigy 2 ZS -> Creative AudioHQ"
- Double-click "Device Controls"
- Select "Decoder" tab
- Select "SPDIF Passthrough"

4) Configure Speaker Settings:
- "Start -> All Programs -> Creative -> Sound Blaster Audigy 2 ZS -> Creative Speaker Settings"
- Select "2/2.1 Speakers"
- Select "Digital Output Only"

need to configure your dvd software, to output via spdif. under audio/speaker environment

5) Reboot

Hope this helps.


Unregistered guest
Ive tried the solution, but my decoder came bundled with an RCA to 3.5mm cable. Also I have 5.1 speakers, setting the speaker settings to 2.1 just upmixes the channels; so I get sound out of all of my speakers but still cant set my decoder to dobly digital or dolby digital EX... in other words im getting no real surround at all out of this thing.

anyone know of another solution?
« Previous Thread Next Thread »

Main Forums

Today's Posts

Forum Help

Follow Us