Like

My ariston won't play records...any advice?

 

New member
Username: Missmera

Post Number: 1
Registered: Mar-05
hey
i have an ariston att 420, with an automatic stop/start funtion. the problem is that everytime i try to play a record, the needle touches the record, then the arm picks itself up and goes back to the rest.
very annoying!
it will do this 20 times in a row, and only sometimes concedes to play eventually.
speed seems to make no difference, neither does putting the needle on manually or using the automatic button.
is this a belt issue?
can i fix it, or should i get professionals involved?
 

Bronze Member
Username: Jan_b_vigne

Dallas, Tx

Post Number: 24
Registered: May-04


You should probably have the table looked at by a service tech. Here's one thing to try before you send it off. With the table unplugged, hold the tonearm firmly and give the platter a good, fast spin. Let the arm move if it wants to, but obviously don't let it sit down on the empty platter. If that doesn't free up the mechanism, then it's time for the techs.




 

New member
Username: Missmera

Post Number: 2
Registered: Mar-05
thank you, I'll give that a go.
 

Unregistered guest
Hello,
I have an ariston ATT-420. The problem is that the turn table does not turn anymore when i try to play a record. I think the ribbon that turns the turn table has come loose but i can't seem to fix it. Can you help?
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us