Like

Speaker static problem

 

New member
Username: Trenneck

New Albany, OH United States

Post Number: 1
Registered: Oct-04
I have a Sony STR DB930 A/V Receiver with brand new Polk tower speakers, and a polk center speaker. I notice a bit of static coming from all speakers at low levels (I believe it is always there, just more noticable at low levels)from any/all sources. I replaced my Boston Acoustic's as I believed it was a speaker problem which it is obviously not. I am thinking it must be the receiver but hate to buy a new one. Any advice?
 

Silver Member
Username: Rh1

Post Number: 358
Registered: Jun-04
Re-check your connections, also make sure your wires are isolated power verse speaker wires. That might be the culprit. Did you have this receiver hooked up before to different speakers?
 

Silver Member
Username: Rh1

Post Number: 359
Registered: Jun-04
sorry, after reading my post it may seem confusing. Make sure your power chords are not crossing your speaker wires
 

New member
Username: Trenneck

New Albany, OH United States

Post Number: 2
Registered: Oct-04
The left/right wires are crossing power cords, but the center is not and all 3 have static. Yes this receiver was hooked up to a set of Boston Acoustics that had the same problem.
 

Silver Member
Username: Rh1

Post Number: 360
Registered: Jun-04
The only other thing I could point towards would be line conditioning. Do you have "snow" on the tv or static when, say you turn on a blender or something?
« Previous Thread | Next Thread »

Facebook

Directory

Main Forums

Today's Posts

Forum Help

Follow Us