Like

Headunit won't turn on. Little Help naa?

 

Silver Member
Username: Vc23

EastCoast, Michigan Dos Fi BLs

Post Number: 368
Registered: Mar-06
So I've installed numerous hu's in my time, and never have been so frustrated. The car is a 2002 Kia Spectra. The hu is a sony somethin or other, its brand new. I ripped out the old clarion and hooked up every wire the exact same... My friend jumped the gun and tried to turn it on before alll the wires were taped over... The only things I can guess are wrong.. the fuse popped, but which one? and also maybe the ground from the original wasn't good enough? If anyone could help out real fast that would be awesome. Thank you.
 

Gold Member
Username: Sinful_systems70

15 INCH WANG...

Post Number: 1338
Registered: Nov-06
I would obviously check the fuse first. You can look in your owners manual, on the back of the fuse box cover and sometimes on the fuse block itself for the fuse locations and functions. If fuse is OK then check fuse in back of HU (if applicable) and possibly check to see If you accidentally tugged on a wire too hard and broke it or possibly pulled it out of the harness or plug. Also I see that you are using tape. Anything else or just tape? Re-check all connections and try again. Sometimes when you use only tape and no solder or connector, then there is a possibility of a bad connection. Had a vehicle come in to the shop once that the HU would shut off randomly and they told me it would happen every time they hit a bump. Pulled HU out of dash and power wire was falling out of the HU plug, so I got a new plug, wired it to the harness, plugged it in, put HU back in dash, then drove down the worst street in my city to test it and had no other problems. Hope that this helps.
 

Gold Member
Username: Sinful_systems70

15 INCH WANG...

Post Number: 1339
Registered: Nov-06
If you do not have an owners manual then google the vehicle's fuse locations.
 

Silver Member
Username: Vc23

EastCoast, Michigan Dos Fi BLs

Post Number: 369
Registered: Mar-06
Thanks for the tip sir, also, His dome light also doesnt work, and his turn signals? but would would that not make the hu not turn on?
 

Silver Member
Username: Joe1234

Post Number: 993
Registered: May-09
Vc23 I think you had a problem with fuses the last time around, lol, how do you manage to get into trouble so often.

Hope you can get a $10 multimeter one of these days, will save you a lot of guess work.

The HU itself has some fuses, have you checked those??

Anyways take a look at the fuse box of the 2002 Kia Spectra:

Upload

Upload

Download the image and zoom it so you can better see.
 

Silver Member
Username: Vc23

EastCoast, Michigan Dos Fi BLs

Post Number: 370
Registered: Mar-06
lol Joe, whenever I do work for other people it seems like I don't care as much, but when I do work on my own stuff it comes out perfect. But yes I checked the fuse in the hu which is very accessible right under the wire harness. And It was cold as ba11s last night so I didnt feel like pulling out all the fuses to check which was which, thanks for the diagram tho, Im sure it'll be an easy fix. I was just too frustrated last night to figure anything out. I'll make sure to give you guys an update later tonight. Thanks again : )
 

Silver Member
Username: Vc23

EastCoast, Michigan Dos Fi BLs

Post Number: 372
Registered: Mar-06
Update, Replaced the audio/dome light/other fuse, and the dome light now works. The HU will now accept and eject cd's, but the lights dont pop on. I took some pictures, and also looked up the original wiring diagram. found here http://www.the12volt.com/installbay/forum_posts.asp~TID~95926. I'm confused with what to do, the turn signal fuse is fine, although they won't turn on for some reason. Pictures coming.
 

Silver Member
Username: Vc23

EastCoast, Michigan Dos Fi BLs

Post Number: 373
Registered: Mar-06
Upload
 

Silver Member
Username: Vc23

EastCoast, Michigan Dos Fi BLs

Post Number: 374
Registered: Mar-06
Welp, the deed is done. Got everything back together, everything is working. Don't ask me how.
 

Gold Member
Username: Joe1234

Post Number: 1001
Registered: May-09
I won't ask..lol.. glad you nailed it again!
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us