Like

Forums down

 

Silver Member
Username: Shortysetnies

Rock Vegas, NC US

Post Number: 860
Registered: Mar-06
Imagine that. Seems to happen a lot.... Check j designs.info it's runnin fine.
(take out the space between the j and designs.info)
 

Silver Member
Username: Mvplefty12

Pinellas, FLA America

Post Number: 449
Registered: Mar-06
Not really a J designs fan, no offense to anyone... just not my cup of tea.
 

Silver Member
Username: Shortysetnies

Rock Vegas, NC US

Post Number: 863
Registered: Mar-06
hey man. as long as you checked it out. thats cool... Youre gonna be an outcast in a couple months if you dont like it but its ok. Haha
 

Silver Member
Username: Tdawg30

Ohio USA

Post Number: 821
Registered: Jun-06
yeah same here, I really dont like the whole layout and such of j designs just cuz I like ecoustics better haha and cuz I have a higher post count here and dont want to be all noobie over there again. Noobs suck!!!!!!!
 

Silver Member
Username: Shortysetnies

Rock Vegas, NC US

Post Number: 866
Registered: Mar-06
noob is about knowledge, not post count
 

Silver Member
Username: Tremor1127

Post Number: 638
Registered: Aug-06
yeah, i needed a subwoofer forum fix after doing a quick install for a friend who has NO BASS IN HIS RIDE! i gave him a subwoofer awhile back and hes like an undercover crackhead or something and never has $$$ so never got around to doing crap with it. yesterday i built a box for it and gave him an amp today...

anyway, im gonna start a thread in here called AUTOTEK MX3000.1 and you should all go in there...
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us