Like

HELP!!! PLEASE!!!

 

John Cody
Unregistered guest
Ok heres what happened:
I was driving around with my stereo blasting. Then was gauges started goin crazy like the speedometer went up to like 100 and came down. And my battery light came down. I lowered my stereo and the car settled down. As went turn the stereo on the battery light kept flashin and the interior lights would dim like crazy. So, I turned the stereo off. So, I went home and turned the car off. Now, the car wont turn on. I tried charging the battery but no luck...it still wont turn on....anybody know wuts wrong? Any suggestion would be good....Thanks....sry its so long
 

Silver Member
Username: Iufan4lifeul

Post Number: 916
Registered: May-05
Get it to a shop. That sucks. Sounds like the alternator is crapping out or something. I don't know a whole lot about that stuff though.
 

Unregistered guest
is as a ford
 

John Cody
Unregistered guest
No, its a 04 Subaru Impreza WRX.
 

John Cody
Unregistered guest
Any ideas to what is wrong?
 

Anonymous
 
mine did the same thing it wont turn over it wont even sound like it is trying to start
 

John Cody
Unregistered guest
Yea, exactly it doesn't even try to start.
 

Bronze Member
Username: Kravenblood

Ohio

Post Number: 35
Registered: Aug-05
lol your alt probably died and your battey died to the point that it cant hold a charge happened to my olds
 

Gold Member
Username: Bestmankind

Los Angeles, CA USA

Post Number: 2421
Registered: Oct-05
i had a similiar problem like that happen to me few years ago. i didn't even have a system in my car. just a stock stereo. anyways, i took it to a shop and they told me my alternator was bad. they either fixed my alt or replaced it and it was fine. best thing for you to do is have a professional look at it.
 

Anonymous
 
well im going to have to load mine up on a trailer and drop it in a shop it suck lol
sorry it wont let me type on my user name so i have post as anonymous my user name is Bret Harris

94 jeep cheroky
 

Gold Member
Username: B101

Queen City, NC USA

Post Number: 1145
Registered: Sep-05
dead battery & alternator is what their gonna tell you.
 

Silver Member
Username: 420pimp2

Post Number: 427
Registered: Jan-06
your battery is most likely still good, your problem is your alternator. Get a new h.o. alt. Put it on yourself and you will save alot of $$$$$. Do you know how to put a knew alt on?
 

Bronze Member
Username: Thunderforce

Netherlands

Post Number: 14
Registered: Feb-06
i think youre ground kabel is not so good, i think if you make it better and clean the problem is gone, also replace the ground cable from your alt
 

Silver Member
Username: 420pimp2

Post Number: 433
Registered: Jan-06
it could be that but highley unlikely, with what he described it sounds like the whole alternator not just a ground wire.
 

John Cody
Unregistered guest
How much does it cost to install an alternator? The warranty will cover the alternator but I think I have to pay for the install...
 

Platinum Member
Username: Glasswolf

Wisteria, Lane USA

Post Number: 11144
Registered: Dec-03
the alternator failed.
seen this happen before.

if you killed one, you'll kill a new one too.
get a high output alternator.
 

Silver Member
Username: 420pimp2

Post Number: 446
Registered: Jan-06
depends on were you go.alternator and install will run around 300 to 400 range. Its not to hard to do it yourself. Get a high output alternator. If you do it yourself youll save 100 to 200 $.
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us