Like

Subs not working

 

New member
Username: Mgreene

Maple Grove, Minnesota United States

Post Number: 10
Registered: Jan-06
Got a RE SX 12 in nov and i hooked everything up but nothing worked, i sent back the amp (hifonics titan tx1505d) and they sent me a new one... while i sent the sub back a friend let me use his old one and that worked but when i got the new amp in the mail and hooked it up... nothing! i used a AA battery and hooked positives together and negatives and the sub moved, so i ruled the sub out. then i bought this rca hookup thing so i could hook my ipod to my deck and BassManMike told me to hook the RCA connectors to the RCA ports on the amp for a really stong signal but still nothing was working... im beginning to think its the amp but its hard to believe that both amps were messed. i kinda thought it was the HU ground but ive tried every place and still nothing. im running out of ideas guys any suggestions? thanks
 

Bronze Member
Username: Mgreene

Maple Grove, Minnesota United States

Post Number: 11
Registered: Jan-06
while i sent the amp back**
 

Gold Member
Username: Sploosh56

Ohio

Post Number: 1095
Registered: May-04
do any fuses blow on the amp? Does it even turn on? If it turns on did you hook it up to the rca Inputs on the amp? Is your amp grounded correctly?
 

Bronze Member
Username: Mgreene

Maple Grove, Minnesota United States

Post Number: 12
Registered: Jan-06
no fuses on the amp are blown, the amp is getting power and when i touch the pos and neg speaker wire to metal they are sparking like crazy.
 

Bronze Member
Username: Call_me_ky

Post Number: 41
Registered: Jan-06
so you get a green light or a red light on your amp... if u get red make sure your ground is goooood. also sometimes the inside of your rca jacks can b messed up... took me a week to figure that out suuucked..

so yea red or green light
 

Silver Member
Username: Alex_f

Lawrenceburg, Ky Us

Post Number: 575
Registered: Nov-05
kyle do u live in ky? cause ur username is call me ky. i live there.jw though
 

Bronze Member
Username: Mgreene

Maple Grove, Minnesota United States

Post Number: 13
Registered: Jan-06
lets just say that my RCA pre amp output blew would all of them be? and would it work if i used the 1st or 2nd output instead of the subwoofer one?
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us