Like

Question about new subs but now less audio

 

New member
Username: Peemoeller

British Colu... Canada

Post Number: 8
Registered: Oct-05
I have just replaced 2 of my 12inch subs with another pair of SAME RATED subs and I am getting dramtically LESS AUDIO. What's this all about?

I do have a basic system ~ here it is! Perhaps someone could shed some light on this!

Amplifier:
Pioneer GM-X802 (7 years old)
2CH 100W x 2 @ 4 ohms RMS
1CH 150W x 2 @ 2 ohms RMS ~ (amp is 2ohm stable)

Original subs x2: (7 years old)
Rock Fos RFP-1812 12inch 8ohm SVC 200 RMS/400 MAX

New replacement subs x2: (new)
Rock Fos P212S4 12inch 4ohm SVC 200 RMS/400 MAX

I have kept the wiring the same in parallel after installing the NEW subs. I thought for sure using 2x 4ohm subs in parallel (2ohm load) would be louder/powerful than my original setup with 2x 8ohm subs (4ohm load).

BUT THESE NEW SUBS ARE SO QUIET.

Any ideas???

My guess is these 2 new subs are "under rated" and I need a more powerful amp. Perhaps 300 RMS to each sub?

Any suggestions appreciated.
 

Silver Member
Username: Bga44

Tampa

Post Number: 135
Registered: Nov-05
Pioneer GM-X802 (7 years old)
2CH 100W x 2 @ 4 ohms RMS
1CH 150W x 2 @ 2 ohms RMS
doesnt make sense. u say 1 ch then 150W x 2?
 

New member
Username: Peemoeller

British Colu... Canada

Post Number: 9
Registered: Oct-05
Sorry I mean:

Pioneer GM-X802 (7 years old)
2CH 100W x 2 @ 4 ohms RMS
2CH 150W x 2 @ 2 ohms RMS
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us