Like

NEED help wits subs

 

Unregistered guest
hi
i have 2 of infinity ref1240
RMS: 300 Watts
Power Handling, Peak: 1200 Watts
Sensitivity: 93dB
Frequency Response: 23Hz - 400Hz
Mounting Depth: 5-1/16"
Impedance: 4 Ohms


And 1 off lenzer vibe vibe261
2400 w
2 x 360 Watts RMS at 4 Ohms
2 x 1200 Watts Max at 4 Ohms
1 x 2400 Watts Max at 4 Ohms Bridged
2 x 800 Watts at 2 Ohms RMS
MOSFET Automatically Switches to Maintain Rated Power Over a Wide Range of Battery Voltages
Stiffly Regulated PWM-Type Power Supplies
Variable Input Level Controls for Each Pair of Cannels
Variable High & Low Pass Crossover Controls
High-Efficiency, Heavy Aluminum Heatsink
Remote Subwoofer Bass Control
Electronic Crossover Network
Bass Boost Circuit
Bridgeable at 4 Ohms
2 Ohm Stereo Stable


I connected just the 2 subs with this amp but
im not satisfied with if im getin hell of a disstorshion plz help me out
 

Silver Member
Username: Big_oso

Post Number: 506
Registered: Jun-05
Check the settings on your amp. If you are getting a lot of distortion then you have your gains set way to high. If you want to properly set your gains without using all the right equipment turn the gain all the way down on your apm then turn the volumn up on your head unit to 3/4 of its max then slowly turn the gain up until you hear distortion then back it off slightly until its gone. That is the lehmans way of setting gains. If it still persists try running a new ground but make sure you sand off the spot where your grounding to. That was the problem i had in my car when there was distortion. Go try those 2 and let me know if that helps.
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us