Like

Amp not powering on anymore, plz help.

 

Silver Member
Username: Goon

Post Number: 282
Registered: Feb-05
Ok, i have an orion hccca 250 hooked up to two infinity perfects. everything was working fine and then everything just shut off. this wasn't after a few mins of working. the systems had been working for a few weeks. the amp doesn't seem to be fried or anything. i didn't notice any smoke and nothing on the board looks burnt. i checked the remote wire and the ground wire several times. no, fuses are blown and the power cable has a solid connection. what else can i check or do to see if i can get this thing working again? there has to be something else. thanks for the help.
 

Gold Member
Username: Carguy

Post Number: 4070
Registered: Nov-04
Use DMM and measure the voltage on the power wires and remote wire. If there is power, then take the remote wire on the amp and lightly touch the pos power wire. See if you see any spark. That should trigger the amp to power on. If you see that, then the amp is good. If nothing happens, then the amp is blown.
If you don't have DMM, get one from Radio Shack, it costs around $10-$20.
Unhook every cable/wires on the amp before doing this test.
 

Silver Member
Username: Goon

Post Number: 283
Registered: Feb-05
when you say unhook all the cables/wires. does that mean the power cable a well? or just the speaker wires and such. thanks again Isaac
 

Gold Member
Username: Carguy

Post Number: 4073
Registered: Nov-04
Everything except the power wires.
 

Gold Member
Username: Invain

Michigan United States

Post Number: 3508
Registered: Aug-04
When you say everything shut off, do you meen just the stuff running off your amp? Do you have anything else in your car running off a different amp, or your headunit that kept playing, or was everything totaly off? You amp could have overheated, HCCA's like to run hot.
 

Silver Member
Username: Goon

Post Number: 284
Registered: Feb-05
The HU kept going, just my amp. yeah it was running pretty hot, but i'm not sure how hot really hot is. i am runnign it at 1ohm, wouldnt it have turned back on? well i picked up a DMM and i will be testing it soon. ill let you guys know how it goes.
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us