Like

What do you think? Give me your opinion.

 

New member
Username: Aviator05

Post Number: 2
Registered: Jan-05
What do you think of this. A Sony X-Plod Amp that is 200 watts RMS x 2 at 4 ohms (250 watts RMS x 2 at 2 ohms)
» 500 watts RMS x 1 at 4 ohms (4-ohm stable in bridged mode)

along with 2 10" sony subs that have a power range of 80-300 watts RMS
» peak power handling 1100 watts

Please give me your opinion of this set-up.


 

Silver Member
Username: Taylor17

Kopperl, Texas

Post Number: 270
Registered: Jan-05
No offence, that system is a low end system. It will sound ok if you are on a tight budget, but it won't sound that good.
Sony isn't that good in the car audio department. People have had a lot of problums with there amp's overheating, not that good of quality!
That's just my appinion, I know a few people who are using Sony amps, and haven't had any real problums with it, as far as I know!:-)
As far as there sub's, I know this kid at my school who as a pare of Explod's, or what ever they are called. He is using a Pioneer 760 watt amp. It doesn't sound that bad, it just won't put out that clean, or have the spl either.
 

New member
Username: Aviator05

Post Number: 3
Registered: Jan-05
What would you suggest that is better than this but not to expensive. Something under $450.
 

New member
Username: Aviator05

Post Number: 4
Registered: Jan-05
What would you suggest that is better than this but not to expensive. Something under $450.
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us