Like

Right side output doesnt work HELP

 

Silver Member
Username: Xxkmfdmxx

Saint Petersburg, FL USA

Post Number: 154
Registered: Oct-04
I recently bought a Power Acoustik amp which works quite decent but I can only put my speakers/subs on the Left output on the amp, When I try to put them on right side aswell I get no sound from that side. Checked the RCAS and they seem to be fine. What could be the problem?
 

Silver Member
Username: Hdubb

Farmington, Nm Usa

Post Number: 195
Registered: Nov-04
are your rcas close to your power wire? that may be the problem. try moving them away from the power wire
 

Silver Member
Username: Xxkmfdmxx

Saint Petersburg, FL USA

Post Number: 155
Registered: Oct-04
Well, I have the power wire wired up on the opposite side of the RCAs so that should be fine.
 

Silver Member
Username: Hdubb

Farmington, Nm Usa

Post Number: 200
Registered: Nov-04
then its probably the amp...they are kniwn to do things like that. which amp is it? i dont know what else it could be
 

Silver Member
Username: Xxkmfdmxx

Saint Petersburg, FL USA

Post Number: 156
Registered: Oct-04
The amp is a POWER ACOUSTIK OV2-520. Im gonna just try to get a refund from where I got it from since I just bought a MTX 311D to power my subs.
 

Silver Member
Username: Hdubb

Farmington, Nm Usa

Post Number: 206
Registered: Nov-04
ya i melted a wire terminal on my pa lt980/2 good fun.
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us