Like

Amp Smoking! reasons why?

 

New member
Username: Oldmenfall

Post Number: 1
Registered: Dec-04
I hooked up my Kicker Sx 1200.1, I ran my wire with inline fuse to distribution block from there to amp.. I ran my ground to a bolt drilled into the floor of my truck I hooked both of these up and my remote wire. I also had my speakers hooked up and my rca's hooked up.. all of my settings were at zero gain...etc. etc. My subwoofer output was turned off on my head unit. I hooked up my power cable to my battery without the fuse in. I then checked to make sure everything was connected and put the fuse in when the fuse was put in the amp started smoking. I pulled the fuse immediately and took it out and pulled covers off and part of the board was black looked like a capacitator on the board was fried it only burnt a small part of the board.. the part where the power came into the amp. I then put my fuse back in and checked my power and ground supply and they were both fine. I used a tester. I think that the amp didnt ground inside of it Bc I had my wires connected fine.. Does anyone know of any reason why this would happen? or if it was a manufactured fault?
 

Gold Member
Username: Glasswolf

NorthWest, Michigan USA

Post Number: 7064
Registered: Dec-03
wiring outside of the amp sounds fine. the amp may have been defective out of the box when you got it.
I'd return it and exchange it for another one.
may have been shipping damage.
 

Silver Member
Username: Lbeckner

Tulsa, Ok Usa

Post Number: 126
Registered: Oct-04
yeah. Sounds like a bad amp. Hope u have a warranty.
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us