Like

Need help wtih kenwood KAC-742 amp

 

New member
Username: Theo22

Post Number: 1
Registered: Dec-04
i have a Kenwood KAC-742 car amplifier. i "basically" know how to set it all up but do i need any special "amp kits" like i've seen and do i need to hook it straight up to the battery terminal and a metal ground "with a fuse of course" or can i hook it up to the fuse box. it's hopefully going in my '78 ford ranger. i hooked up a few speakers to the amp and put a wire to the fuse box from the "batt" screw and the ground screw. but there is also a + "pcon" possibly "power controller" which someone said it's what shutss off the amp when the key is off. but all i get is a little bit of crackling or noise from the speakers but no actual music. i was just using some regular small speaker wires to do this. do i need one of those amp kits i saw with huge cables?? they are around $100 so it kinda isn't my top choice if the amp doesn't even work. i just want some decent sound outta my ol' truck. o and i probably need soem wiring upgrades to right? thicjer wires?? so basically i have no sound fro mthe speakers with the amp in place. seems to me like there isn't any power i nte amp. is there a way to test it??? i also noticed i got a 15a fuse and it is maked o nthe am that it is a max of 25a. do i neet to add more "symptoms" of my prob?? just ask me if so.

thx.
 

New member
Username: Theo22

Post Number: 2
Registered: Dec-04
o also there is this adobe manual but it ain't helping me very much but maybe it can help you guys undertsand what kind of amp i am putting in my truck. ftp://docs.kenwoodusa.com/manuals/OM-KAC-742-1992-KUSA.pdf
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us