Like

Amps not working

 

LOST
Unregistered guest
My amp (4 channel) was working fine then i unbridged my 2 12" w3s and i was gonna hook up two more 12"s then the warning (red) light came on and it goes green then back to red flashes sorta then it just stays red...i checked all my connections fusses...ground...i dont know whats wrong ne help would be nice
 

Silver Member
Username: Glasswolf

Post Number: 978
Registered: 12-2003
probably too low of an impedance.
 

LOST
Unregistered guest
so what should i do?
 

Silver Member
Username: Glasswolf

Post Number: 986
Registered: 12-2003
what's the voice coil configuration of the subs?
give me that and I'll give you an ideal wiring setup.. or as close as you'll get.
Ideally, you'd switch to a mono sub amp for those JLs.

are they 12W3s? 12W3v2s?
 

LOST
Unregistered guest
i was trying to find out what was wrong today when the amp started smoking...i had problems with it b4 i bought it about 2 years ago (when i was new to car audio...i also bought sony xplod 12's....big waste of money) and the amp was a Jensen 600 watt 4 channel...yes walmart cheap stuff...i have the 2 12" JL w3d2 (discontinued)..could u tell me some good mono amps for my 2 subs...i only have around $200...thanks glass
 

Silver Member
Username: Glasswolf

Post Number: 995
Registered: 12-2003
JBL BP600.1
$210 www.etronics.com
600wRMS x 1 @ 2 Ohms
1 Ohm stable, with same output as 2 Ohms.
good amp.
 

LOST
Unregistered guest
ok thanks glass
 

LOST
Unregistered guest
Well today i called the local audio store (audio force in Johnstown PA) they must not have any idea whats going on...they tried talking me into a bazooka 500 watt amp for my subs (they dont sell the JBL) for 230? but that amp is on here for 160.. and bazooka is sh!t and they said that the jbl amp will fry my speakers or something like that...i ordered the JBL 600.1...thanks glass i trust u more then those Fuc*s
 

Gold Member
Username: Glasswolf

Post Number: 1020
Registered: 12-2003
I wouldn't go with a bazooka amp for sure.
seen far too many of them fail.
they're right in there with pyramid.
their bass tubes work well for cheap solutions, but man those amps are total junk.

hey for that JBL amp, buy a pair of RCA Y-splitters, so you can run input signal to all 4 of the amp's inputs.
trust me, it'll make a big difference for that amp. For some reason, the JBLs work much better when all of the inputs get full signal.
Two of these would be what ya want:
http://www.knukonceptz.com/productDetail.cfm?prodID=KLS1F2M

cheap, effective trick with JBLs.
 

LOST
Unregistered guest
Thanks for all the help..i basically told them to kiss my a$$ haha i know not to buy bazooka...im not totally blind haha well thanks for every thing ill order those tonight...thanks for all ur help..i know how to wire all that..thanks again glass
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us