Like

Amp goes into protection mode

 

Brix
Unregistered guest
My amp keeps going into protection mode. It only happens above a certain volume, but that volume is just barely audible. I hooked it up last year and it has been working fine (even at deafening volumes) until a few days ago. Where should I start? My setup is a Pioneer head unit with preamp output to the amp (Performance Technique).

Thanks
 

Gold Member
Username: Glasswolf

NorthWest, Michigan USA

Post Number: 4572
Registered: Dec-03
sounds like it could be a few things.
amp may be defective
may be a dead short somewhere in the wiring causing thermal protection
could be too low of a load on the amp also causing thermal protection.
 

Brix
Unregistered guest
Thanks GlassWolf. The amp is still under warranty. I just didn't want to go through all the trouble of shipping it back if it seemed like something simple. I'll have to read up about the "too low of a load on the amp also causing thermal protection". I don't know what that means really.
 

Gold Member
Username: Glasswolf

NorthWest, Michigan USA

Post Number: 4614
Registered: Dec-03
that means if you have below a 2 ohm load on the amp, or below 4 ohms if the amp is bridged, it will shut off due to drawing too much current and thus too much heat.
this is a common problem with people starting out and miswiring their amps and speakers.
 

Bronze Member
Username: Ctx

Post Number: 75
Registered: Jun-04
you might try another amp on your subs to make sure its not the subs, my freinds amp kept goin into protect mode and it turns out one of his voice coils was jacked up
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us