Like

JL audio 500/1 and SWR-1241d install help

 

New member
Username: Figment727

Tulsa, Oklahoma USA

Post Number: 1
Registered: Oct-04
I have a alpine cda-9831 head unit, and I just bought 2 alpine swr-1241d and a JL audio 500/1 amp, I cannot figure out the best way to wire these and also have no clue on what I am doing with the knobs and switches on the amp, The subs are mounted in a Q-logic type 2 box, i also dont know if I should leave it sealed or ported. I would really appreciate all help with wiring, amp configuration, and ported or sealed. Thanks for any help.
 

Bronze Member
Username: Comet345

Orlando, FL USA

Post Number: 67
Registered: Sep-04
Hey, how is that alpine 9831? I was thinking about getting it.. www.jlaudio.com ... go to the amplifier section, then go to the JL 500/1 technical sheet ... it shows you how to adjust the knobs properly as well as what the knobs do etc... since that amplifier puts out the same amount of power at any impedence between 1.5 and 4ohms, as jonathan suggested, wire both your subs in parallel and see how that sounds, if it sounds underpowered, then wire them in series and see the difference... Also, check the spec sheet on those subs to see what alpine recommends about the box configuration... usually, sealed boxes give a better bass response and sound tigher, while ported boxes hit bass harder and lower

if I am wrong in any of those facts, anyone please correct me ...
 

New member
Username: Figment727

Tulsa, Oklahoma USA

Post Number: 2
Registered: Oct-04
I like it, I have only had it in for about 3 days, so I havent figured out what all it can do. I tried wiring subs in parallel and they sounded very distorted, any suggestions on how to get them to sound clean?
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us