Behringer feedback destroyer pro DSP1124P hum


Bronze Member
Username: Kinggimp82

Post Number: 48
Registered: May-05
i just hooked up a Behringer feedback destroyer pro DSP1124P. the first day i hooked it up everything sounded fine. although the sub made a popping sound when i turned the unit on. which it does everytime i time i turn it on. is that bad?

i played around with it and the next day i turned it on and now my sub has a loud humming sound. is this a ground loop problem? can i use the feedback destroyer to remove the hum or is the unit most likely causing the hum? im going to try connecting the sub to the same surge protector as my other equipment and see if that helps.

any help would be appreciated,

Silver Member
Username: Bvan

Cape Town, Copenhagen,...

Post Number: 286
Registered: Jun-05
popping not good, been advised to leave bfd on all the time. apparently it draws as much power in idle 'as an owl sleeping'.

Gold Member
Username: Thx_3417

Bournemouth ...

Post Number: 3991
Registered: May-05
Always turn the AVR and other electronics on FIRST! Turn on power amplifiers and sub etc last and power down with amplifiers and subs last you should hear the popping sound then because your powering up and down in the right order.

Top Deals

Loading, please wait...
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message



Main Forums

Today's Posts

Top Deals

Forum Help

Follow Us