Like

Denon AVR-1602 jumps from Dolby D to PL II - does not recover

 

My Receiver had been rock solid for about 2 months but now it seems to be jumping out of Dolby to Prologic and never recovering. I am currently removing my subwoofer from the top of my stereo cabinet to see if that was causing the problem but I am skeptical because it didn't do this for 2 months previous. Even when I watched Das Boot, K19, and Gladiator this did not happen!!! Any direction would be appreciated.
 

Greg Lee
Do you have analog L/R connected up between DVD player and receiver, as well as a digital audio connection? (Assuming it's a DVD player you're using.) If so, you could try disconnecting the analog L/R cables. The receiver could be switching to analog mode, for which ProLogic is appropriate, if it's losing the digital signal (possibly a bad connection?) or just making a bad decision to use analog for some other reason.
 

ryan
I think I found the problem. I had a RCA cable for my subwoofer that needed a splitter which was not an RCA splitter and in fact when wiggled it would correct the problem momentarily. When it was replaced the symptom did not re occur. How can that cause the receiver to bump into PL II from Dolby I am not sure. Can a damaged connection in the subwoofer cable cause excess current to be drawn from the receiver, forcing some sort of over current circuitry to kick in for a period of time?

Top Deals

Loading, please wait...
« Previous Thread | Next Thread »

Facebook

Directory

Main Forums

Today's Posts

Top Deals

Forum Help

Follow Us