Like

Logitech Z680 and SB Live!

 

New member
Username: Brian041878

Post Number: 1
Registered: Oct-04
Hello,

I would first like to say I really appreciate what you guys are doing here. Very helpful!

My issue:
I have a pair of logitech Z680 speakers. I have them pluged properly into a SB Live! sound card that has 5.1 support. I have the newest drives (i just got them), however I seem to be getting no sound what so ever from my center channel, everything else works fine! In my drive control panel I cannot pick anything higher than a 4 speaker system when this is a 5, that is what I would think is the obvious issue. The problem is... why is it max at 4? Anyone had this problem before?

Thanks for the help!
Brian
 

New member
Username: Redknight

Atlanta, GA USA

Post Number: 2
Registered: Nov-04
Hi Brian,

I'm new to the forum - I hope you've got your problem figured out? If not,

I would directly contact Creative tech support. It sounds like a very precise question - the type that tech support might actually answer intelligently. :-) It's an issue with their audio control panel, obviously.

One other question - you say you updated your drivers. But - and I may be wrong - their "Control Panel" application might be a separate download from the driver itself. (Or do they come as a bundle?) Anyway, I'd double-check that I got all the applicable downloads. Technically the driver is one set of software and the audio control panel is another, but exactly how they package it for download, I don't know.

One other thing is that I see you got no answer to this particular question, here. These eCoustics boards seem great for car and home audio, but as you can see, this particular PC message area is barely visited. For PC support in general, I highly recommend Compuserve's free PC Hardware forum at http://go.compuserve.com/pchardware. Lots of experts jump on most every PC post there.
 

New member
Username: Wheaple2325

Post Number: 1
Registered: Jul-05
Hi, I just bought the logitech z-680 speakers and I was wondering how you are supposed to connect them to a playstation, or anything besides the computer. Also my center channel is not working with my computer. I thought it might be bc i have a laptop and i dont think that i have a 5.1 sound card, but all the other speakers are working fine.

Thanks a lot.
-Brad
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message
   

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us