Like

Alpine TypeR/Kicker DX issues

 

New member
Username: Ohmsconfusem3

Post Number: 2
Registered: Aug-19
Ok so, this is gonna be lengthy but I want to try to be as detailed as possible before I throw in the towel! lol

I have a 10in Alpine Type-R with dual 2ohm voice coils

Its powered by a Kicker DX500.1 that is 1,2,4ohm stable. (500w/rms at 1ohm down to 140w/rms at 4ohm)

So for YEARS now, Ive unknowingly been running this set up with good results but in the 4ohm configuration. Went to do some tinkering today.

Found my subwoofer was wired with the Kicker jumper in the 4ohm configuration (the jumper going from the + on one VC to the - on the other VC, the power cable connected to the open connectors)

Dont get me wrong, it hits quite well surprisingly. And has ran for YEARS.

Figured Id try for the 1ohm set up to get the full 500rms that the Kicker AMP is capable of. So I found the second jumper in my garage, wired for 1ohm (one jumper connecting the two + poles, the other connecting the two - ones)

Well I cannot get even HALF of the bass out of this configuration without it putting the amp into Protect mode. Im baffled. I tried adjusting settings on the AMP. Even with the gain all the way down! I set my music to my normal volume, slowly turn the gain up. Get about a quarter of the way up and boom. Red light!

But with the set up that does work listed above, my mirrors shake and I FEEL the bass with the gain set about half.

I’m lost!

Please
Help!!!
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message
   

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us