Like

DD3515s & M3 Install...

 

Gold Member
Username: J_baby15

United States

Post Number: 2228
Registered: Feb-06
Subs: 2 DD3515e
Amp: DD M3
Box: 9.5cuft w/ 10" flared port tuned to 36hz.

Box is mostly done, got a few more things to do before I can put it in, but I'll have install pics up tomorrow.
 

Silver Member
Username: Mystre

Pemberville, Ohio USA

Post Number: 475
Registered: Sep-05
can't wait to see the pics, what about a video?
 

Platinum Member
Username: Nd4spd18

Philadelphia, PA

Post Number: 11408
Registered: Jul-06
hey hey, jordan singelton... when did you get back on the forum lol
 

Gold Member
Username: J_baby15

United States

Post Number: 2229
Registered: Feb-06
Haha man I've been gone for a while but I make a visit. I'll get vids but at the moment Im not wanting to push it too hard until I upgrade the electrical. It's raining out today so it's slowing me down.
 

Gold Member
Username: J_baby15

United States

Post Number: 2230
Registered: Feb-06
Got some work done today. It's in the truck for basically a "test fit" and to make sure everythings working right. Next weekend I'll be getting the amp rack made, as well as pulling the box back out to get carpet put on. Anyways, heres where it's at right now:

Putting deadener on the tray. This is what the box will be sitting on.
Upload

Picture of the 10" Port.
Upload

The M3
Upload

This where the amp will be temporarily until next weekend when the rack gets made. Also, going to clean up the wiring then.
Upload

Dropping the Subs in.
Upload

Upload
How the box sits.
Upload
 

Gold Member
Username: J_baby15

United States

Post Number: 2231
Registered: Feb-06
I still have a lot of work to go before it's done, but I'm happy with the sound so far.
 

Silver Member
Username: Jbpitt

Pittsburgh, Pa. Usa

Post Number: 809
Registered: Jul-09
I bet thats loud as hell! Nice amp too!
Got any vids coming?
 

Silver Member
Username: Jbpitt

Pittsburgh, Pa. Usa

Post Number: 810
Registered: Jul-09
"I'll get vids but at the moment Im not wanting to push it too hard until I upgrade the electrical."

Nevermind
 

Platinum Member
Username: Nd4spd18

Philadelphia, PA

Post Number: 11417
Registered: Jul-06
what kinda truck is that?... last i knew you had a cadillac. lol.
 

Gold Member
Username: J_baby15

United States

Post Number: 2232
Registered: Feb-06
The Cadillac got rear ended and totalled. Haven't had that since like 07 haha. That's a 02 Dodge Ram Quad Cab. I've messed with it a litte more today. I can barely turn the amp up any without the clipping light coming on, still gets loud enough for some descent flex on the doors and back window. I'll see if I can get a video of it. Definately ready to get the electrical upgraded tho, right now I just have the factory 110a alt and a redtop under the hood.
 

Platinum Member
Username: Nyyfan13

Northern VA

Post Number: 11961
Registered: Jul-06
I got excited to see a BMW M3

Shows how much audio is on my mind lately lmao. Good looking install though Jordan.
 

Gold Member
Username: Delsole

Post Number: 1728
Registered: Feb-05
^^ I was saying to myself, how the he!! are you gonna fit two dd15's in an M3. But the the i opened the thread.



Its looking good though. I'd love to see a vid.
 

Gold Member
Username: J_baby15

United States

Post Number: 2234
Registered: Feb-06
haha noooo. I'm ready for the weekend to get here so I can clean it all up, hopefully everything goes as planned.
 

Platinum Member
Username: Insearchofbass

2 hifonics 2607s, 2dcSounds12xls SPL\idmax12SQ

Post Number: 15355
Registered: Jun-04
looking good....good choice in subs too
 

Gold Member
Username: Andrew571

Stillwater/Edmond, Oklahoma USA

Post Number: 2371
Registered: Oct-05
Looks loud forsure.


Though I thnk someone jizzzed on your sonotube.
 

Platinum Member
Username: Insearchofbass

2 hifonics 2607s, 2dcSounds12xls SPL\idmax12SQ

Post Number: 15425
Registered: Jun-04
any videos?
 

Gold Member
Username: J_baby15

United States

Post Number: 2235
Registered: Feb-06
No Vids. I got the box covered in rhinoliner, along with an amp rack. Install was good, sounded great. Was going to make a video but a couple days afterwards the engine went out. Threw a rod and all the oil dumped out.

As it is now, no pics of the new install and I might even have to pull it out and sell it all depending on repair costs.
 

Platinum Member
Username: Nd4spd18

Philadelphia, PA

Post Number: 11482
Registered: Jul-06
You do not have good luck with cars do you
 

Gold Member
Username: J_baby15

United States

Post Number: 2237
Registered: Feb-06
Not at all. Everything was good, had no problems at all with the motor up until this point. I'm lost on where to go from here. I just got it all in and put together, 2 more batteries coming soon. Now this...
 

Platinum Member
Username: Insearchofbass

2 hifonics 2607s, 2dcSounds12xls SPL\idmax12SQ

Post Number: 15586
Registered: Jun-04
oh man im sorry to hear about your bad fortune
 

Bronze Member
Username: Canaanwhite

Monroe, Louisiana USA

Post Number: 42
Registered: Nov-10
man that suxs...I hope you can get it fixed soon
 

Gold Member
Username: J_baby15

United States

Post Number: 2239
Registered: Feb-06
Got to pick the truck up today. It all got fixed but set me back $3200. I'm going to try and put everything back in tomorrow evening and have a video up.
 

Silver Member
Username: Canaanwhite

Monroe, Louisiana USA

Post Number: 230
Registered: Nov-10
Were you able to get it back in yet ?
 

Platinum Member
Username: Insearchofbass

2 hifonics 2607s, 2dcSounds12xls SPL\idmax12SQ

Post Number: 15818
Registered: Jun-04
im interested too and would like to see vids
 

Silver Member
Username: Makinblak

Monroe/Monticello, La/Ar

Post Number: 126
Registered: Oct-10
Lets see a good pic of that rhinoliner
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us