Lit-up like an X-Mas tree, but no functions or sound?!?


New member
Username: Koaco

Post Number: 1
Registered: Nov-06
I have a 1995 VW Jetta III GL. I pulled my old (stock) radio because the buttons were lit, but the LED display did NOT light up and it would not play tapes or radio. It had done this sometimes in the past if I left a tape in the deck. I had to eject the tape (the radio would play) and then re-insert the tape. The last time, however, it never played again (radio or tape).

I purchased a VR3 CD-R/CD-RW/MP3/USB/SD Card head unit from Target (kill me for being cheap, but my car's a piece of crap anyway)... :-)

I found the Jetta's wire colors on this forum (thanks!), wired the new radio as follows:
1) all speakers correctly
2) ground correctly
3) Constant power correctly
4) switched power to "Power" AND "Panel Light"
5) Did NOT connect antenna (need to add a straight connection (car had a 90-degree conx)

Nothing happens with the key in the ignition (the old radio -when it worked- used to play just by inserting the key). Once they key is on "Run", though, the radio lights up and the LCD display is completely lit up. Pressing buttons doesn't do anything and it will not accept a CD, nor is there ANY sound.

I popped the face plate off and pressed the RESET button with a pen. Still does the same thing.

I am completely stumped (and I fear that I threw out a perfectly good stock radio in the process - though I like the new one anyway). ;)

Any ideas?


Silver Member
Username: Jenifer_contreras

PIMP Member, Yokosuka, Ka...

Post Number: 625
Registered: Jul-06
Cheap HU ! straight to


Gold Member
Username: Mixneffect

Orangevale, Ca. USA

Post Number: 1154
Registered: Apr-05
Read the instructions carefully. I had a home theater dvd/vcr combo i installed for a friend and nothing worked until we set the clock, lol. Settig the clock initiated the program setup, lol. Sometimes you can run into a complete off the wall setup like this, so dont get discouraged. You may find a totally unexpected glich. Best thing to do is to backtrack everything. Hope you find the problem. :-)
« Previous Thread Next Thread »

Main Forums

Today's Posts

Forum Help

Follow Us