Like

Is it possable for HU cause humming?

 

Bronze Member
Username: Quig

Pittsburgh, Pa Us

Post Number: 96
Registered: Sep-05
Ive tried 2 differnt grounds and the 2nd is better then the first, but it still taps my subs and still has a humming noise. right now its nto a big deal but in a couple days i want to power my 6x9s of an amp and i tried it already, when i turn it on full then the humming noise is outrages so i need to get ti fixed. so can someone give me all the possabliltys to fixing the humming noise. ppl r saying its my rcas but i tried regrounding them by attaching a wire to each and grounding it, and it stays the same so its not the rcas.
 

Silver Member
Username: Van_man

Boston, MA

Post Number: 364
Registered: Mar-06
Does your hu have a good ground? you might try a ground loop isolater inline with the rca's. This is a last resort thing if you have ruled out the bad ground theory.
 

Gold Member
Username: Goatin

Ohio U.S.A

Post Number: 1124
Registered: Jan-06
Are Your RCA's At Least 2'(feet) apart?

If not they need to be.

""ppl r saying its my rcas but i tried regrounding them by attaching a wire to each and grounding it, and it stays the same so its not the rcas""

That is pointless ^ And it will not help, I would think if anything it would make it worse.
 

Silver Member
Username: Van_man

Boston, MA

Post Number: 369
Registered: Mar-06
rca routing is a myth. yes grounding outside rca terminals can help in some situations. but not many. more likly bad HU to begin with or weak link in the grounding system or power system.
Sorry to Dis'you Rave'n.
 

Bronze Member
Username: Quig

Pittsburgh, Pa Us

Post Number: 97
Registered: Sep-05
where is the HU grounded at? (When i installed it i dint kno much about car audio)
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us