Like

I need help aahh

 

Bronze Member
Username: Volsrule2069

Post Number: 36
Registered: Feb-05
alright so my dashboard lights werent working so me and my dad changed the fuse and now my speakers dont work. my subs still work and they do just the same except i have no music with the bass. i checked the fuse for the radio and the speaker wires and it all looks ok. whats goin on???
 

Silver Member
Username: Nemen

Post Number: 754
Registered: Dec-05
you sure all u move was the fuse and are you powering your speakers off your head unit? did you try to take the fuse out again and then see if it works?
 

Bronze Member
Username: Volsrule2069

Post Number: 37
Registered: Feb-05
yea i checked the fuse it was good. it even works every once in a while but not usually. what else could cause this im pretty sure no wires are loose
 

Silver Member
Username: Goatin

U.S.A

Post Number: 905
Registered: Jan-06
Are your dash lights working? lol

I would pull off the fuse cover there should be a diagram on it and go over all of the fuses and make shure they are all good, in place and the right size.
and there is another fuse box under your hood.

I assume your HU is working ok besides nothing but bass.
Are you useing a factory HU?
 

Gold Member
Username: Young_james

Canada

Post Number: 1384
Registered: Sep-05
had the same prob in my gf's car. Ended up being that one speaker shorted out, causing all to go except the sub
 

Bronze Member
Username: Volsrule2069

Post Number: 38
Registered: Feb-05
yea my dash lights work at the expense of the sound hahah. no i have a panasonic. i really hope its not a short in the speakers bc my 2 from speakers are impossible to get to, but i think your right cus i had a problem just like that in my other car.

any tips on how to get to speakers you cant see that are buried in your dashboard right at the bottom of your windshield?
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us