Like

After 3 years, i'm done

 

Silver Member
Username: Terps297

Potomac, MD USA

Post Number: 169
Registered: Oct-04
after 3 years of wanting, waiting, wishing to put a system in my car, it's in, i had 2 8's for a month and then i decided to upgrade to this, i'm happy right now and i don't think i'll need anything more than this, if you can see theres only 2 amps, i was orignally gonna put three of the X600.1's in there but i decided to break in the subs with 1 but i found out that those subs with only 200rms a pieces is plenty for me.

i'll tell ya, after working in my garage for 6 hours for 4 nights in a row with a friend, it really paid off, we took a drive after we finished and we couldn't stop smiling, a sweet success with no hitches and great results!

i want to thank all of you who are willing to helpe all of us who know less but want to learn more. i've been looking and learning from you guys for 3 years now and i can say that i know a good amount, but i still want to learn more. Upload



Upload
Upload
Upload
Upload
 

Silver Member
Username: Terps297

Potomac, MD USA

Post Number: 170
Registered: Oct-04
the pic of the 8's in the ported box is what i had before, powered by a eD 9.2

my 200 amps alt and 0 ga wire
and my trunk before
Upload
Upload
Upload
Upload
 

Gold Member
Username: Rovin

Trinidad & T...

Post Number: 6999
Registered: Jul-05
hey , looks good man bet it sounds SQL

all left 4 u 2 do is carpet the box

U also now have the privilage 2 post ur install in the bragging section of thsi forum
........Upload
 

Gold Member
Username: James1115

Ct

Post Number: 5458
Registered: Dec-04
looks nice man
 

Silver Member
Username: Lbeckner

Tulsa, Ok Usa

Post Number: 841
Registered: Oct-04
3 years and no carpet on the box... just kidding. nice looking install
 

Gold Member
Username: B101

Queen City, NC USA

Post Number: 2149
Registered: Sep-05
your amps and subs in the trunk and still got room :-) sweet install man..

my trunk :-)
Upload
 

Silver Member
Username: Solacedagony

New Jersey US

Post Number: 865
Registered: Oct-04
Very pretty. Awesome job!
 

Bronze Member
Username: Re_baby

Okc, Ok Usa

Post Number: 18
Registered: Mar-06
thats awesome is it loud where did you get that setup
 

Silver Member
Username: Matt12490

Benicia, California USA

Post Number: 505
Registered: May-05
wait... what are your new subs?
 

Silver Member
Username: Matt12490

Benicia, California USA

Post Number: 519
Registered: May-05
Ooh Ok nevermind they're soundstream. how do they sound?
 

Bronze Member
Username: Nanbakat

Mexico CityMexico

Post Number: 26
Registered: Mar-06
Where did you get the inline fuse holder that I see placed on top of the battery? It looks like it has an LED read-out. Does it tell you the battery voltage or what?

Great job...
 

Silver Member
Username: Terps297

Potomac, MD USA

Post Number: 171
Registered: Oct-04
|\/|aTT |F : the subs sound great, in the sealed box they are very loud, maybe i haven't lost my hearing yet but they can get a little too loud haha, i love them.

Bret Harris :i got all of my stuff online from various websites

Nanbakat : it's part of the Voodoo 0ga wiring kit that i got, yes it does have a voltage read-out and it's very handy.
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us