Like

Master/slaving trouble

 

Bronze Member
Username: Kwrubel21

Shelby Township, MI United States

Post Number: 31
Registered: Dec-05
alright i'm having some trouble hooking up 4 twelves in my brother's trunk.
he's got 2 amps: one for each pair of subs.

i think we have everything hooked up right, but only one amp will turn on. occasionaly, both will turn on but only one will have amp protection on.

does anybody have ANY clue as to what is wrong here?
 

Gold Member
Username: Southernrebel

Monroe, Louisiana USA

Post Number: 1739
Registered: Mar-04
what amps...and what subs?
(what voice coils do the subs have?)
 

Bronze Member
Username: Kwrubel21

Shelby Township, MI United States

Post Number: 32
Registered: Dec-05
2 directed D2400 amps
and 4 12" directed sx subs

there dual 4 ohm
 

Gold Member
Username: Rovin

Trinidad & T...

Post Number: 3553
Registered: Jul-05
is a REM wire from the HU on each amp ????......
 

Gold Member
Username: Rovin

Trinidad & T...

Post Number: 3554
Registered: Jul-05
is a REM wire from the HU on each amp ????......
 

Gold Member
Username: Rovin

Trinidad & T...

Post Number: 3556
Registered: Jul-05
is a REM wire from the HU on each amp ????......
 

Gold Member
Username: Bestmankind

Los Angeles, CA USA

Post Number: 1255
Registered: Oct-05
lol rovin you really want an answer to that question there don't you
 

Gold Member
Username: Rovin

Trinidad & T...

Post Number: 3569
Registered: Jul-05
i kept getting an error message & thought my original post did not go throught @ the time ....
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us