Like

Need urgent help

 

Silver Member
Username: Dominirica012

Charlotte, North Carolina US

Post Number: 293
Registered: May-05
i know this doesnt really belong in this forum but this is the most people are
The Problem
ok i had a 2000 Galant but my mom has it now because she sold her car well yesterday i let her drive my car to work and she said that my amp wasnt working..turned out to be the rca jacks went out although im not worried about this because i got a replacement...the real problem is thta when i was at bestbuy nothing electrical worked when the car was off(power locks and the remote for the alarm) but it did when the car was on but the RPM of the car goes up and down from like 200-800 then the car shuts off unless its moving...i open my trunk at i find that the amps power wire(the one from the battery) is loose and it seems that it might have made contact with the negative wire.
If anybody has any idea what happened can you please tell me and hopefully it aint to serious because if it is my dads gonna kill me :-(
 

Silver Member
Username: Tbolt

Collipark, GA

Post Number: 205
Registered: Dec-04
Did you check all the fuses.
 

Silver Member
Username: Dominirica012

Charlotte, North Carolina US

Post Number: 294
Registered: May-05
yea thats what i was thinking i did check them but their didnt seem anything wrong although i couldnt really look in depth because i felt that if i stayed close to my dad for too long my life might be threathened
 

Silver Member
Username: Tbolt

Collipark, GA

Post Number: 206
Registered: Dec-04
Even the ones under the hood.
 

Silver Member
Username: Audiobass10

Cape Coral, FL United States

Post Number: 115
Registered: Jul-05
"yea thats what i was thinking i did check them but their didnt seem anything wrong although i couldnt really look in depth because i felt that if i stayed close to my dad for too long my life might be threathened"

Yea make sure to check all the fuses. One time a while back my amp wouldnt turn on and I took out the fuse, which looked fine. I took it in to my local car audio shop to get tested and indeed it was blown. Sometimes u can tell and sometimes u can't.
 

Silver Member
Username: Dominirica012

Charlotte, North Carolina US

Post Number: 295
Registered: May-05
o....didnt check those..i mean i aint worried about getting it fixed because my uncles a mechanic and he gonna fix it im just worried that some part(s) might have gotten damaged and that theyll cost alot to replace
 

Silver Member
Username: Dominirica012

Charlotte, North Carolina US

Post Number: 300
Registered: May-05
im good now turns out ti was just a fuse lol
« Previous Thread | Next Thread »

Facebook

Directory

Main Forums

Today's Posts

Forum Help

Follow Us