Like

Only One Speaker Works..

 

Unregistered guest
I have a 1990 Chrysler Lebaron, and i put in a Durabrand AM/FM CD player stereo, i even bought the harness adapter and the dash adapter. ALl my peakers worked fine until a month or two after my drivers side speaker started sounding like it was blown, i looked and its fine, after that it went out and no sound at all, then a couple months later both rear speakers died, i have no idea whats going on but if someone can help please do, i don;t wann have to spend alot of money on a stereo system. Thank you very much.
 

Kyle Allen
Unregistered guest
Chris, I'm not sure if it is the same problem, but it may be. I had a similar issue with a clarion I purchased. What happened was that the outputs went out of my cd player. Which basically means its shot. Luckily my warranty cover the defect. My speakers did almost he exact same thing. You should test each speake individually to help verify this. I hope this helps. Once again it may not be the same problem but it sounds very similar.
 

Silver Member
Username: Illuminator

Post Number: 574
Registered: Apr-05
Yeah, given the reputation of Duraband there is little doubt that it needs parts to function correctly again.
 

Unregistered guest
Well lol i figured it out this morning, i put my old stereo back in and tested it, and all my speakers are fine. so i guess you are right Kyle. Stupid durabrand cd player.. oh well what do you expect from a 40 dollar cd player? lol anyways thanx for the help guys.
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us