Like

Noise Issues..

 

New member
Username: Blitz666

Post Number: 1
Registered: May-05
Ok i really need help with this.. i been trying to find a solution for over 1 month and havent seemed to be able to find one.. So here is the Problem..
Im running a Pioneer DEH-p5650MP head unit and 2 amps.. 1 mono block just for the bass) and one 4 channel for my speakers..

My problem is that When i turn my head unit on, it makes Really stupid noised.. It sends constant THUDDING Noises to my speakers and sub..
when i move my head unit around while its on it makes static noises, when i tap the RCA cables at the back of the head unit u can hear it through the speakers and sub.. but i never seemed to have a problem until i disconnected my RCA cables out of the SPEAKER AMP while it was playing ( and yes i know that was stupid )... could it be that my head unit is damaged?? coz i changed my rca cables and i still get the same problem.. Also.. it makes a fast TIC tIC TIC TIC noise at times.. from what i know, i havent changed any cables around that could cause this.. even when the car is off.. i still seem to be getting what appears to be engine Noise..

ANY HELP Would be great..!!
 

Silver Member
Username: Illuminator

Post Number: 222
Registered: Apr-05
You would be best off looking at this: http://electronixwarehouse.com/education/accessories/aboutnoise.htm

I'm guessing that you might have your power wire too close to your RCA signal wire somewhere in your car.
 

New member
Username: Blitz666

Post Number: 2
Registered: May-05
well, i got my head unit checked out by the place i got it.. they reckon that the RCA on the back of the head unit HAS BEEN used up and has been damaged.. i gotta wait and see what happens//. thanx
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us