Like

I need some help

 

New member
Username: Adi20_1979

Post Number: 1
Registered: 02-2004
i have an amp called "Concord" model CA2050 I need schematics or something like that.I hava a little problem with power and i don'tknow what.PLS help
 

Unregistered guest
have you tried contacting the amp manufacturer directly? what kind of power problem are you having? schematics help a great deal theres no doubt about that but also checking for continuity, resistance and a sine wave (oscilloscope) can do wonders in absence of a diagram..do you have the equiptment for those tests?
let me know what kind of problem your having and ill see if i can point you in the right direction.
jay
p.s. i can tell you this that most amplifiers have 2 very common problems which would be no audio output is typically blown ic's and no power or intermittent is a loss of ground or loose and or bad ground circuit which you can trace that on the board without a schematic. but in any event let me know and ill help in any way i can.
 

New member
Username: Adi20_1979

Post Number: 2
Registered: 02-2004
the amp is "working" .when i installed in the car with the motor stop it was working but with the motor on the power led starts blinking,and the music cuts off after aprox 2,3 sec is on then after 2,3 sec is off again.
I don't know what is the manufacturer of the amp.
 

Gold Member
Username: Glasswolf

Post Number: 1098
Registered: 12-2003
Concord is the manufacturer.
it's a cheap amplifier.
the problem is most likely a weak alternator, or insufficient power wire gauge.
 

Bronze Member
Username: Gecko

Post Number: 23
Registered: 01-2004
as wolf said or a bad GROUND connection
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us