Like

Im new to the car audio market and i just bought my first amp..

 

New member
Username: Jush

Post Number: 1
Registered: Dec-04
I just recently bought a volfenhag amp, and im worried if that was the wrong decision heres what i bought VOLFENHAG ZX-8300 4 CHANNEL 1200 WATT AMPLIFIER NEON NE. If you could please give me some advice on my amp, that would be appreciated
 

Silver Member
Username: Carguy

Post Number: 858
Registered: Nov-04
Hey Jimmi, what kind of advice are you looking for? You already bought it. It's not the best amp, but it's certainly better than Pyramid. Use it and see if it delivers as advertised.
 

New member
Username: Jush

Post Number: 2
Registered: Dec-04
Thank you Issac! I have herd that they are not the best, but are they better than Sony or audiobahn? I also paid $268 for the amp, did i get a bad deal on the amp or what should have i bought? Thank you, I appreciate it!
 

Bronze Member
Username: Protrex

Post Number: 28
Registered: Sep-04
You PAID WAY TOOOOOOO MUCH. That amp isn't worth more than $160 shipped.

http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&category=4950%26item%3D5737383364% 26%26

It's not a bad amp, but I would not pay for than $160 for it.

Return it. Fast.

-Jamie
 

Silver Member
Username: Xxkmfdmxx

Saint Petersburg, FL USA

Post Number: 110
Registered: Oct-04
Volfenhad amps I think are decent, But as Jamie said, you paid WAY too much for that, for $268 you could have gotten a way better amp. Where did you buy it if you dont mind me asking, Cause that was one hell of a rip off.
 

Silver Member
Username: Carguy

Post Number: 868
Registered: Nov-04
Hey Jimmi, I'd say they're better than Sony and Pyramid. Hook them up and try it out. You never know, you could end up liking it.
 

New member
Username: Jush

Post Number: 3
Registered: Dec-04
The amp was only $133.33 but i live in Canada so i had to pay $135.00 for shipping, so i paid 268 total, i bought it at www.sonxicelectronix.com
 

Silver Member
Username: Carguy

Post Number: 871
Registered: Nov-04
Whoa, that's a rip off shipping! I only paid around $50 the most for an amp. Anything less than $200, the shipping can not cost more than the product itself (for amps).
I'll check out the site.
Next time shop around, and you'll see better vendors. I have couple that ships smartly so that you don't get killed in shipping/handling/duty.
 

Silver Member
Username: Oleg

Santa Monica, CA USA

Post Number: 156
Registered: Nov-04
The amp's advertised at 300Wx2 in bridged mode, but I doubt you'll be able to get any more than 200Wx2 out of it. Yeah, next time ask for advice when you can actually use it, because even though now you know, are you reall going to return it?
 

New member
Username: Fletchpug106

Post Number: 1
Registered: Dec-04
ot. can anyone help me? ive bought an spl sub and amp and can't get itr to work! for give me but i havent got much of an idea about these things! ive got sub connecet to amp correctly (cant go wrong!) and got power cable and earth cable connected correctly. the RCA? cables with one red plug and 1 white i've but in the rear out put in the back of my head unit. but i'nm worried that little blue lead maybe wrong? i think its called remote lead or something. where should it be connected to? basically power is gettin to the amp but the sub still win't work! please help me!
 

Bronze Member
Username: James1115

Ct

Post Number: 35
Registered: Dec-04
well dude from the sound of your post it doesnt sound like you really know what you are up against my friend. Well there are two options. 1)bring it to a shop and have them do it the overpriced way or 2) Try to figure this out yourself in that case I will tell you that if your remote wire is not hooked up corectly you will not get sound to that sub. Your amp will be getting 12v power from the battery but not ign power. I dont know what kind of head unit you have but it is normall pretty standard that the remote lead off the back is always a solid blue. So hook that up and give it a go if it doesnt give a shout back and maybe we can try to help you out a little more.
James
 

New member
Username: Jush

Post Number: 5
Registered: Dec-04
Do you know what the website for volfenhag amps is? where they are made, and where the repair shop is.

Thanx alot!! Jim
 

Silver Member
Username: Oleg

Santa Monica, CA USA

Post Number: 163
Registered: Nov-04
I can't find it and they want to make sure you won't either!
 

Bronze Member
Username: An_eagalach

Annandale, VA US

Post Number: 30
Registered: Aug-04
Their website is http://www.volfenhagaudio.com/contact.html
 

Silver Member
Username: Solacedagony

New Jersey US

Post Number: 140
Registered: Oct-04
Volfenhag is low end stuff.
Also, the remote lead is there so that your amp isn't constantly on so that you don't run your battery down everytime you turn your car off. You need to put a switched 12v line into that. I usually just the wire that goes to the head unit. So if you don't have the hooked up correctly, your amp won't even turn itself on.

It sounds to me like you should take your stuff to a shop somewhere and have them hook it up for you. That way you don't end up just wiring stuff together, destroying your audio equipment and maybe the electrical system of your car. Just my thoughts.
 

New member
Username: Fletchpug106

Post Number: 2
Registered: Dec-04
yeh blue lead is in right place!any other ideas?

RCA?

bus audio rear front
O RED O RED O RED
O WHITE O WHITE O WHITE

if got the cables in the "rear" section is that correct?
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us