Like

Best Wiring Setup For 2 Memphis 12's

 

New member
Username: Swanks

Post Number: 1
Registered: Nov-04
Just recently installed my stereo into my new vehicle. Currently im running what you see in my sig minus the 0 guage wire. Im running 4 now.

KAC-X301T Excelon Series

Ok heres the problem. Currently this is how i have everything setup.

Both Memphis wired in parallel so that the ohms are dropped to 2. I then have ran one wire from one speaker terminal to the other speaker terminal dropping the ohms to 1. I then bridged at the amp dropping me down to .5 ohms. The amplifier i have IS stable down to this, I know this for a fact as ive ran many setups in the past this way. It is an excellent amp and ive not had a single problem with it yet. I also am using my 1 farad cap. This is how i setup the cap. I ran the power wire to my fuse breaker, then from there to my cap and from my cap to my fuse block/splitter. From there my power wire is ran to my amp. I ran seperate grounds to the chassy for both amp and cap. Im using gold plated stinger terminals on the cap and battery.

I have been noticing that my cap will cut out quite alot lately and just turn off then back on sometimes. Ive checked all connections and everything is secure. Also along with this I can only run my system for about 5 minutes before it will cut out for about 10 secs and then cut back in due to the amp protection.

From here i unbridged at the amp and dropped back to 1 ohm. The same problems have occured. Currently im just running channel to channel without any issues but of course lacking alot of Bass which i could be getting.

Now I am thinking either step up to a more powerful amp or possible get a bigger alternator and seperate battery.

Any ideas? Also any other ideas on wiring these to get the max out of them?

[img]http://www.pixfiles.net/pix/1528/DCP00459.JPG[/img]

[img]http://www.pixfiles.net/pix/1529/DCP00460.JPG[/img]
 

New member
Username: Swanks

Post Number: 2
Registered: Nov-04
Sorry i meant in my profile, anyway heres my current setup.

Clarion Pro Audio Head Unit
2 Memphis Studio 12in Dual 4 DVC
Ported Undivided Premade Box
Kenwood KAC-X301T Xcelon Amplifier
Hi Wave 1 Farad Digital Cap
0 Gauge Power Wire, Custom Amp Rack
 

New member
Username: Swanks

Post Number: 5
Registered: Nov-04
-BUMP-
 

New member
Username: Swanks

Post Number: 6
Registered: Nov-04
Did some more researching and fixed the problem. Turns out I never rewired the subs and they were still wired normally to 4 ohm and i had actually goofed by wiring to 2 sets of terminals which seemed to throw some weird voltage into the system.

Wired down to 1 ohm/1 set of terminals and bridged at the amp.

 

New member
Username: Swanks

Post Number: 8
Registered: Nov-04
http://www.rockfordfosgate.com/rftech/wiringwizard/2_4ohmDVC_1ohm.gif
« Previous Thread | Next Thread »

Facebook

Directory

Main Forums

Today's Posts

Forum Help

Follow Us