Like

Fuses keep blowing in amp

 

New member
Username: Daddyluv02

Post Number: 7
Registered: Aug-04
I have a JBL 600.1 amp and I keep blowing the fuses. Do I have the wrong fuses in or something because it came with 30a fuses? Or is it something else. Thanks
 

Silver Member
Username: Joe718

Brooklyn, NY

Post Number: 239
Registered: May-04
that amp requires atleast a 60 amp fuse from the battery because it has 2 30amp internal fuses
 

New member
Username: Daddyluv02

Post Number: 9
Registered: Aug-04
Well, I looked at the specs on line and have a 1200 watts power kit and it says that the fuse included is 100a. If this fuse blew, would the amp still work? If this situation is not feasible, what else could be the problem?
 

Silver Member
Username: Joe718

Brooklyn, NY

Post Number: 245
Registered: May-04
that amp shouldnt pop a 100 amp fuse. I would check all my wiring. Make sure none of the wires got knicked in the instillation. Like the power, remote, and patch cables.
 

Gold Member
Username: Glasswolf

NorthWest, Michigan USA

Post Number: 5977
Registered: Dec-03
if you blew a 100A fuse, you either have a dead short inside the amp and it needs to be replaced or repaired, or you have a short in the wiring somewhere causing the fuses to blow.
 

New member
Username: Daddyluv02

Post Number: 10
Registered: Aug-04
Is blowing the fuses in the amp hurting the amp? Also could it just be my luck that I had two fuses go out if it does not happen again?
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us