Like

PPI A300.2 bridge?

 

Krazy Karl
Unregistered guest
I just dusted off my old PPI ART Series A300.2 and hooked it up in the old Camry. I'm running it in stereo to the two subs but can't remember how to bridge it. I know it's stable down to like .5 ohms or something crazy so I was going to bridge/parallel the subs. If anyone has some advice on which taps to use for bridge mode I'd love the help. There are no markings on the amp itself which I thought was strange.

Thanks for any assistance.
 

Silver Member
Username: Fishy

Tamarac, FL USA

Post Number: 273
Registered: Sep-04
I guess the guys at Directed are pretty lame. They don't have any .pdf's for anything discontinued, much less the old school stuff.

I've got an old pro MOS-2050, but luckily its got a lil sticker on the bottom with the wiring specs.

Somebody here has got to have an Art Series amp. If no one posts and you get desperate there's a A300 manual on ebay at $3 plus $3 shipping.

http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&category=18796%26item%3D5723282129 %26

good luck :-)

-Fishy
 

Silver Member
Username: Koz1031

Monticello, In United states

Post Number: 196
Registered: Jul-04
you could always get in touch with Directed tech support. They may be able to help you out.
 

Silver Member
Username: Fishy

Tamarac, FL USA

Post Number: 278
Registered: Sep-04
lol, yeah that would be less lame than droppin 6 bucks on a couple pieces of paper.

:-)

-Fishy
 

Silver Member
Username: Fishy

Tamarac, FL USA

Post Number: 279
Registered: Sep-04
Come to think of it I sent those guys an e-mail with regards to my pro MOS having a subsonic filter and I never received a reply, but maybe you would have better luck with the phone.

-Fishy
 

Krazy Karl
Unregistered guest
I can't believe that they don't have .pdf mauals online like everybody else. I just read the one for my EQX (which has the inverted mono out for non-brigable amps) which came in very handy.

Unless somebody here can help, I may try the tech-support black hole and pray for rain.

thanks.
 

Silver Member
Username: Fishy

Tamarac, FL USA

Post Number: 293
Registered: Sep-04
I remember those old PPI's that needed a "bridging module". Didn't really know what that was but figured you could use an Audio Controls Xover's inverted out to get around it.

Thanks for the confirmation.

:-)

-Fishy
 

Bronze Member
Username: Sas

Post Number: 56
Registered: Sep-04
i have an old blacl ppi a300 art series amp and an old white a600.2 white art series amp, i can find them and cheek it out
 

Silver Member
Username: Zacdavis~

Post Number: 151
Registered: Sep-04
left positive, right negative.... all art series and powerclass series. i collect them
 

Silver Member
Username: Fishy

Tamarac, FL USA

Post Number: 347
Registered: Sep-04
I saw a black Pro Art 100 on ebay a while back.

Got one of those yet? the black ones don't look nearly as rediculous. The curvy white looks of the other ones don't match their ferocious ability well IMO.

:-)

-Fishy
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us