Like

Clifford Matrix 2.5 problems

 

Unregistered guest
hi all..i am new to this so let me just explain..i got this matrix 2.5 installed at bestbuy in february..its worked flawless until today..when i got back from the store and tried to arm it..it wont sound and the light in my window stays on ..solid red..i arm it and the doors lock but no sound..and it unlocks ok also..one more thing..whenever i turn off the ignition now..the light comes on again..solid red.without me even arming it..its always on when the car is off...can someone help or tell me what the problem could be..thanks for any infomation given
 

Bronze Member
Username: Jeremyc

Kunsan AfbSouth Korea

Post Number: 92
Registered: Jun-04
Yep it is in vallet mode. You probably entered this mode by bumping some of the buttons on the remote. Look in the manual, and see how you take your alarm in and out of vallet mode via the remote. Easy fix.
 

Anonymous
 
This is less of a problem and more of a question. I was told that the Clifford Matrix 2.5 can get mods added to it (i.e. remote windows, remote stereo, shaved door kits, ect..) but after reading a few threads it looks more like its only the Viper that can do that. Am I just looking in the wrong areas or is this true? And if mods can be added, can a weekend mech. install it or is it professional only?
 

Silver Member
Username: Jeremyc

Kunsan AfbSouth Korea

Post Number: 481
Registered: Jun-04
yes you can add the mods with the clifford.

It is possiable for some people to install a alarm, but I sugest most people let a professional do it. It can get a little dificult if you don't know how to figure out what wires you need.

Look up the alarm in the clifford web site, if you want to know all the options.
« Previous Thread | Next Thread »

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us