Olympus panoramic smartmedia card formating


New member
Username: Ems3_cateas

Dont want to tell, Dont want to... Uk

Post Number: 1
Registered: May-04
Hi I am trying to format my smart media card to enable panoramic header on a non Olympus card.
I have tried the instructions I found (copy document attached)
any one had any success?

Please email me on



adding panarama to smart media card.

Olympus Panorama Header
The panorama feature on Olympus smartmedia can be overwritten by other devices, causing you to lose the panorama function. It is possible to restore this feature.
This is for information purposes only. The described procedure has worked well for restoring or adding the panorama capability to smartmedia cards of any brand, however if you decide to try it yourself, it is possible that you could make your card unusable unless you have the proper program and reader/writer to restore it. Deciding whether to try it is your own responsibility, and if you don't have the same card reader and program as used here, you might have to modify the procedure to fit. If you don't know what a hexadecimal number is, and understand how they work, it may be best not to attempt this. It is actually rather simple, but does require some basic computer knowledge and care.
Before you start, go to to get a basic idea of what you're doing, and what the CIS (card information structure) is. Don't do the procedure exactly as described on that page, as it's not entirely correct (or clear), but do try to understand what is being done.
Go to and find, download, and install a hex editor if you don't have one. The A.X.E. editor is free and works well, though it will ask you to register it to a nonexistent address. Recently, some have not been able to locate this editor, but any hex editor will do, there are several available as shareware.

Newer Olympus camera?? Read this!!
A few of the latest models apparently won't work with the "OLYMPUS PAN 1.0" info, it needs to be changed to read "OLYMPUS PAN 2.0". This is a very simple change. When modifying the second file, put the number 32 in place of the last number 31 (toward the end of the underlined numbers below). Check the results in the ANSI text panel.
This change to 2.0 is reported to be backward-compatible with older cameras, so it should be safe to do regardless of which model you have.
The following procedure is done with a Zio USB smartmedia reader, Windows 98/ME/2000, and the smprep.exe program that is installed with it. No instructions are given for other readers, as I don't have them to work with, so if you're using a different reader, you may need to figure out any differences. However, the CIS should be the same, so if you can locate that in your version of smprep.exe, you should be able to accomplish the same thing.
Load the smprep.exe program into the hex editor. It may make things easier if you widen the "bytes" window as below to 16 numbers wide. If you save it as you work, do not overwrite the original file by using the same name.
Step 1: Locate the beginning of the first copy of the CIS. You can use the edit...find feature to search for the following string: 01 03 D9 01 FF (see red underline below). To make the first hacked version of smprep (the one that damages the CIS), change the first 01 to 02.
Figure A

Step 2: Find the second copy of the CIS, which uses the same string as the first one; you can probably just scroll down a few lines and find it, or you can use the search feature again to find it. (see figure B below). Change the first 01 to 02. Save the file as smprep1.exe.
Important! After saving the copy of smprep1.exe, close it, and open the original smprep.exe. Do not use the altered copy you have just made to begin the second hack! After you have opened the original file again, proceed as below:
Step 3: Look at figure A above. As you did the first time, locate the first copy of the CIS, and find the string of 20's (underlined in fig. A with blue). Starting at the first 20, change the numbers to the ones shown in red in Figure B, which are underlined in green. Note in the right panel, that this changes the information to read OLYMPUS PAN 1.0. Look at your file, and look at the numbers here...are they all the same? Is there a 00 before the numbers you changed, and an FF afterwards?
Figure B

Step 4: Now, scroll down to the second copy of the CIS, find the same string of 20's as underlined in blue in figure A, and change these also to the numbers underlined in green as shown in figure B. Both copies of the CIS should now be identical. Save this file as smprep2.exe.
Finally: Insert the smartmedia card in the reader. Run the smprep1.exe file, and let it "fix" the card. It should report no CIS and will attempt to fix it, but you will get an error. Then run smprep2.exe and it will again fix the card, this time correctly, and it will also add the Olympus Pan header. You should get no errors this time.
For the first version, the one that damages the card's header, you changed only two numbers, the first 01 in each of the two copies of the CIS.
For the second version, you overwrote 17 numbers, which began with a string of 20's, doing this identically in both copies of the CIS, which added the Olympus Pan 1.0 information.
If you run into problems, you should be able to run the original smprep.exe file to restore the card without the Olympus Pan header. The Olympus smartmedia reader does not come with this program, so beware if you try this with anything but a Zio USB reader and the smprep.exe that comes with it!
This procedure has been reported to work with several different USB readers, as well as a PCMCIA smartmedia reader. Some readers appear to have the identical smprep.exe file as the Zio. If you have a Sandisk reader, there have been some problems with doing this, so be sure to download and install the latest drivers and smprep program from the Sandisk website...otherwise, the card may not work properly even if you do the procedure correctly.


New member
Username: Inoall

Hull, East Yorkshire United Kingdom

Post Number: 2
Registered: Aug-04
It is a little old this post but if your still there have you tried formatting with a computer it worked for me

Steve EZVZ Webmaster
Unregistered guest
Full instructions and required programs are located here:

Steve EZVZ Webmaster
Unregistered guest
Never, ever, reformat your Olympus SmartMedia card on your PC. Likewise you should never, ever, delete pictures from the card on your PC or do anything that causes your PC to write to a SmartMedia card that is used in an Olympus camera. It is VERY likely that the PC will trash the card such that the Olympus cannot read it and cannot even re-format it. Blame Olympus for that one. If you do trash your SmartMedia card in this way then full instructions for repairing it (and adding Panoramic capability while you're at it) is at

Unregistered guest
I have a similar problem: After having put a smartmedia card (from a Olympus camera) in a computer, the card can only be used in this computer. I have downloaded from sallyand steve the two smprep.exe files, but when I run them I get the message: smartmedia drivers are not loaded. Must I use the AXE3 program to edit the smprep files??
Hope for help, I have destroied two card!

Unregistered guest
Steve, thanks for undertaking this. I too am getting the "smartmedia drivers are not loaded" message. Any fix for this?

New member
Username: Lemansfan

Alpharetta, Georgia USA

Post Number: 1
Registered: Dec-04
Hello all. New here but not to Olympus SmartMedia problem. I have too burned a few SM cards in an unexplained manner. It seems that Windows XP alters the FAT table and corrupts the card. Conseguently an Olympus camera (4 different models) will not read or format them. Still searching for a fix besides sending the card back to the manufacturer.

Unregistered guest
Not sure if this works for all but.......I formatted my burnt SM cards in my PoGo Ripflash MP3 player, put the card back in my camera and boom...they work again. Still a huge pain but at least its portable.

Steve EZVZ Webmaster
Unregistered guest
Ah. I think the above programs might only work with certain makes of Smartmedia crad reader hardware.

Keith W
Unregistered guest
I've been following this chain and wondered if there were any updates yet to the "smartmedia drivers are not loaded" issue? Steve?

Unregistered guest
Just messed my SmartMedia card, too. What is the correct way to delete pictures from the cards? I had been transferring them to my pc then deleting them from the card. Or are we just supposed to keep buying more and more cards each time one is filled up? I have an Olympus D-490 Zoom


Unregistered guest
Try reading the instructions that came with your camera. It is quite easy to delete photos one at a time or the whole card at once on a Olympus D-490Z.
I'm following this thread because I have the dreaded "card error" on several cards. I too have downloaded the smprep.exe files and get the "smart media drivers not loaded message".

Unregistered guest
Could people post information with which card readers they have successfully used this famous smprep.exe?

My system shows the same error as I try to use that program.

Unregistered guest
I've used Sally and Steve's pair of smprep.exe
files successfully with a ZiO! reader. Thanks
Sally and Steve for saving my card.


Unregistered guest
Do you know which ZiO reader you used?

Unregistered guest
Hi All,

I have the same problem, but with an XD card. Any idea how to fix an XD card.


New member
Username: Angryzeena

Post Number: 1
Registered: Jan-05
I formatted my SM card using my card reader and computer-oops! Now I cannot download pictures from the camera to the computer. The photos can be seen on the screen of the camera so they are there. This is an older olympus D-340L and I run XP.

Unregistered guest
When I run smprep1 (from Sallyandsteve) on my Kingston 128MB Smartmedia card using a Zio USB reader on an XP system, it does a full format and gets all the way to the end than says the CIS is corrupt and ends the program. Tried it on a Kingston 64MB card and same thing, tries to do a full format gets to the end and quits. Any thought

Unregistered guest
I am yet to try this! (have all working cards at the moment but will try it out on a 16mb one I have spare and see what happens).

Some points to note:
1) Deleting files shouldnt be an issue its just formatting on the PC which isn't a good idea. Also you may find that disconnecting safely (through the device manager) is a good idea. It appears that Win2k can have problems otherwise (XP seems to be fine so far).

2) The smprep files appear to be for the ZioUSB reader (hence the instructions to perform similar hack to other programs). So if you get problems then suggest you see if you can find a similar smprep program supplied with your cardreader and hack that.

3) The process is as follows (once you have your modified programs):
a) Run smprep1.exe which will reformat and add a "BAD header" to the card (this will kill your card and CIS will be corrupted!)
b) Run smprep2.exe will format the card again, but since the header is damaged it is able to rewrite the full header and not just part of it as before. Now your card will work.

3) You should find that an unmodified version of smprep or smprep2 should fix any PC/bad formatted cards if you don't need the PAN header info. This is probably the safer option since you are not killing the card header!

Note: smprep2.exe appears to be setup to write "OLYMPUS PAN 2.0" in the header. I don't know if this might cause a problem with devices which use "OLYMPUS PAN 1.0" or not.

I shall try all this out using a Jenoptik (JenReader Smartmedia) which I got from ebuyer for 1.17 FreePP. I will first see if there is a smprep.exe or similar on the driver CD and if so I'll edit it as the site suggests and let you know of the results.

Unregistered guest
what is the fix for Windows XP when you get the msg "SmartMedia Drivers are not loaded"?

Unregistered guest
Still looking for fix when I get the msg "SmartMedia Drivers are not loaded.

Unregistered guest
Was having the problem with SmartMedia after formatting on PC. Went to electronics store and purchased Dazzel DM-23500 for 24.94. I am running W2K and when I inserted the cd got msg that program was 16 bit. Plugged in the USB cable and the drivers were loaded from W2K. Used the smformat.exe I got from the web and did a lowlevel format. This completed and was able to use SmartMedia in camara again. Nothing else was done. My camara is a Olympus C3000. Still got msg about drivers not loaded when I tried to run smprep1.exe.

Unregistered guest
The results of my tries was that I got "SmartMedia Drivers are not loaded" which just means that my SmartCard reader is not compatable with the smprep1.exe and smprep2.exe. I tried editing the software provided with my reader but I was unable to find the "byte string" in question so I couldnt change it.

Could you post a link or attach the smformat.exe perhaps that has the "byte string" inside which can be changed (I'll look if you post it). Although if may not work with my reader, it looks like yours works (i.e.does a normal format).

Unregistered guest
I did not load any drivers. Just plugged in reader and ran smformat.exe and clicked on format and it did a low level format. Put card into Olympus C3000 camara and it worked. Have 2 64Mb and 1 128Mb cards.

Unregistered guest
Have also a look here:
This site may help, if you need to reanimate a SM card.

Unregistered guest
Hope someone can help, I'm on vacation in Europe and just had a "card error" on my 512MB XD card... just because I re-formatted the card on the computer. Is there anyway to fix this? hoping there is a quick solution :-(


Unregistered guest
My XD card was working fine in my Olympus 5050 but now says it needs to be formatted - I tried to format it through my Olympus 5050 and I just get card error and I can't use it. Any suggestions?

New member
Username: Sunnybrook

Ithaca, NY USA

Post Number: 1
Registered: Apr-05
I have an Olympus D-3000 which uses smart media cards. My dazzle usb 2.0 reader screwed up the formatting on several cards and I have been desperately trying to find a solution.

Well, here it is. I contacted (zio makes the dazzle) and they sent me an upgrade software for the dazzle and a formatting program. It did not work. On the second go around, they sent me photorescue card wiper freeware ( CAUTION!!!! When you run the wiper, IT DEFAULTS TO YOUR "C" DRIVE AND WILL WIPE IT UNLESS YOU SCROLL DOWN TO YOUR CARD READER DRIVE. Plug in the card, open the wipe prgm, select the card reader drive, and wipe the card. Next open the formatting pgm and run it. Plug the card into the camera and it works!!!! Good luck.

Unregistered guest
A couple friends gave me SmartMedia cards. They both insisted the cards worked. One of the cards came from a guy who only used it in his Olympus C3000 (same as mine); the other card was used in an MP3 player (the flag should have gone up with that one). Upon installation to my Olympus C3000, neither of the cards worked nor was the camera able to format them. I tried my Digital Concepts USB card reader as well as my PCMCIA card reader but neither would even recognize the card as a removable drive much less enable formatting of the card. I tried the smprep.exe, smprep1.exe, and smprep2.exe routines but none of them would work and all of them gave me the "smartmedia drivers are not loaded" warning. Of course, I got the "card error" warning on the camera. The only thing that worked was "smformat.exe". Upon recognition of the card in my USB reader, it presented a popup window that displayed a "format" button. Both chips formatted in a matter of moments on the computer but required a second formatting in the camera to be recognized. I couldn't be happier. Now, I have an extra 32Mb and a 128Mb to take on vacation. Thank you very much for smformat.exe.

Seth J
Unregistered guest

I recently purchased a cheap cardreader to try and fix a formatting problem on my 64MB
smartmedia card. (I used it in a Rio 500 MP3 player). It's the usual story - my olympus camera displays "card error" whenever I try to use the card. Unfortunately, the reader is not
compatible with the smprep1.exe and smprep2.exe files. I do, however, have hex editing
software so I downloaded the image files on

However, I've realized that nothing I write on the card after the memory address 3FFFh is
actually "written." (I've used formatting software, Hex editors such as AXE and image restore
software.... all with the came result.) The software always says that the data was written,
but when you pull the card out, all of the memory after 3FFF displays "FF". (Everything
before 3FFF, however, has been correctly stored.)

I do not believe that either the card or the card reader are defective for the following

1. I can use the full 64MB capacity when the card is inserted in my MP3 player, so I don't
think the card is defective.
2. I can write anywhere I want on an 8MB card that I have using my card reader, so I don't
think the card reader is defective!

Does anyone have any ideas about why I can't seem to write anything on my card after 16K
(address 3FFFh)? I would appreciate any insights anyone could offer.


Unregistered guest
I have tried everything above to get my card to work in my Olympus camera again. The PhotoRescue site is not freeware and only allows a demo to view photos it can recover. The other programs such as FlashDoctor give the error message "Please plug in the specific reader" or something to effect of "drive not found". I have a cheap USB 1.0 reader that did not come with any software. Any suggestions?

Sweet 2
Unregistered guest
I'm using a 2.1 MP.. this morning i took some pic but when i went to download the pictures i got a reading that said card error how do i fix that

New member
Username: Gardenrodent

Post Number: 1
Registered: Jun-05

I wonder if anyone knows, or knows where I can find out, what is the difference between an Olympus panoramic JPEG and any other JPEG? I want to be able to 'fix' some of my images so that the Camedia software will stitch them automatically although I didn't shoot in panoramic mode...


Unregistered guest
I went to and got Recovery Manager (freeware). This allowed me to recover the images on the smartmedia card and then format it. When I put it back in the camera (D-360L) it recognized the card but wanted to format it. I let it format it and now is operating again and my card reader on XP can see it again. No pan though.

Unregistered guest
I was unable to get Recovery Manager to full format. It did do a quick format but my Olympus C700 camera still would not recognize it giving the usual error message. This card worked until I reformated it to use in an MP3 player. I've tried several other ideas above but no luck so far. I plan to avoid Olympus cameras in the future.


For anyone interested I was able to fix my smartmedia card using PNY's SMFormat utility available on there website. I don't think it support panoramic but does work for different kinds of readers.

The Other AJS
Unregistered guest
The easiest way to do it -- if you're a Linux or Mac user -- is to borrow a brand-new Olympus branded card of the same size {not necessarily the same family; this should work even if one is xD and the other is SM}, plug it into a slot reader, and use the `dd` command to read the raw data from the card. {Windows users should be able to do this by booting from a liveCD such as Slax }

First you need to find out where your slot reader is mounted. Plug it in and insert the brand new card. Now try {for Linux -- not sure about Macs cos their file system is arranged a little different than Linux / Classic Unix}:
fdisk -l /dev/sda
fdisk -l /dev/sdb
and so on up to sdh, till you find one that works. That should be your memory card. Then just use something like
dd if=/dev/sda of=memory_card_image
to read the brand new card, and
dd if=memory_card_image of=/dev/sda
to write the image back. You can use bzip2 to compress the image file.

Thanks 'Other'....I found myself in this exact situation with a corrupted 512 xd card. I used your linux commands (running Mandriva 2005 LE) and all seemed to work well. The bad xd card took the disk image and when I fdisk -l to it; it show the identical information.

[root@localhost bill]# fdisk -l /dev/sdc

Disk /dev/sdc: 524 MB, 524288000 bytes
16 heads, 63 sectors/track, 1015 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/sdc1 * 1 1015 511525+ 6 FAT16
Partition 1 has different physical/logical endings:
phys=(1014, 15, 63) logical=(1014, 15, 47)

When I put the 'bad' card back in the camera (Olympus C-8080) it still gets the Format/Power off error message.

Can you offer any other linux based ideas?


Steve G of sallyandsteve
Unregistered guest
Someone asked: "Note: smprep2.exe appears to be setup to write "OLYMPUS PAN 2.0" in the header. I don't know if this might cause a problem with devices which use "OLYMPUS PAN 1.0" or not."

My Olympus 3000Z expects pan 1.0 but works fine, with panorama mode, with a card formatted with pan 2.0

(of Sally-and-Steve fame).

Unregistered guest
THANK YOU to this forum!! For any others who have this Smart Media problem connected with Olympus cameras, i was able to FIX mine using VAIOsoft Recovery Manager mentioned in an earlier post. It's freeware that has an option to format the cards. While the full format did not work for me, the quick erase DID work.

The first time i placed the reformated card in my Olympus D-490 it didn't work (as usual), but i removed the card and tried again - HOORAY - the camera asked me to format the card!!!

This is after months of trying many other solutions and options listed in forums on 3 different Smart Media cards. Until now my Olympus camera was unusable even with brand new cards.

Hope this works for the rest of you too. Here's the link:

If you have any questions you can find me at Thank you all as i can now use my camera!

Unregistered guest
I have several old smart media card readers but only the Dazzle smart media card reader has the smprep.exe file. I was able to reformat my 128 cards using a lexarmedia smart card reader, drivers from lexar and Windows 98. I did a complete physical format using this reader and restored function of the cards. My Olympus C-3000 Zoom re-formatted the card to complete function.

Unregistered guest
Klaus, THANK YOU!!! My Olympus D-490 Zoom showed 'NO CARD!' even though my card reader showed pictures on the card on my PC. I just tried what you said and moved the card in and out a few times to clean the contacts and now it is working! I am so happy! Thank you for the tip and I hope this helps someone else. Keep trying if it doesn't work at first.

Unregistered guest
Still the "card error" with a 128MB SanDisk SM card. Nothing has worked yet. Not even the linux "disk image cloning" (thanks to The Other AJS) taking the SMVIRGIN128.DAT from Australia's borge
and not the cloning (again under linux) of a working 16MB Olympus SM card. Is there any information around to what extent the "sector zero" (incl the CIS data) is specific to the manufacturer? Can somebody indicate the sector zero for a working SanDisk 128 MB SM card? Then I would try to write this one on my SM.

Unregistered guest
If all else fails try this website.
I tried to load the drivers into my windows xp machine but no success. I gave this company a shot and they delivered as promised.

"SmartMedia Drivers are not loaded" probably refers to the drivers necessary for the card reader to work, not about the card itself...
Using SMPREP1.EXE and then SMPREP2.EXE helped me to recover my smartmedia card, without getting any error message.

Unregistered guest
Well, I see that I'll give the commercials a try. My feeling is that it is specific to the card reader whether the suggested solutions work or not. Modern "x-in-1" readers may work less well because they cannot give access to the corrupted "invisible" sectors where the card information (CIS) is stored.

Unregistered guest
It worked! I found a person in Germany who offers to repair SmartMedia cards. My SanDisk 128MB now works again without problems. The issue is to have the right, "sufficiently old" card reader that has access to the "invisible sector" (physically below the partition table) where the card information (CIS) is stored. If you pay the mailing to Germany and send a nice postcard or picture, then this person may help you. Here's a link:


I am purchasing a 512mb Transflash card to use in my new digital phone (Samsung a950). The card some with an adapter so you can use it as a "SD" card. I want to find out if I can use this arrangement in my Olympus Camedia camera which uses a "smart media" card. My idea was I could just swap the card as neeed. Will this work?

I am purchasing a 512mb Transflash card to use in my new digital phone (Samsung a950). The card some with an adapter so you can use it as a "SD" card. I want to find out if I can use this arrangement in my Olympus Camedia camera which uses a "smart media" card. My idea was I could just swap the card as neeed. Will this work?

Unregistered guest
None of the above helped to me, but formatting in Digitech GNX3 Guitar Pedalboard did. My camera accepted the SM card without any errors. So, if you know somebody playing guitar, it might be a solution.

Unregistered guest
I've got the same problem with 8Mb SmartMedia.
I've tried lot's of things described above but they didn't help because of card reader. I get error messages while using smprep1.exe & smprep2.exe, smformat and others.
Has anybody got working 8Mb SM card please make image of the card and send me on email:
I think this should help me or advise something.

OK... my card also could not be read by my Olympus C-700 Ultra Zoom. I was able to rescue all my pics and save them iwth PhotoRescue off of a P2P. I formatted the card on my pC oops. Then got it to format on the camera. Took some pics and then voila Card Error.. I have gotten it to format with VAIORecovery as stated above, but the when prompted on the camera to format, I get the card error again. It comes up in Recovery with no errors so mine like your problems must be deeper ... No solutions here just my experience.

Unregistered guest
Has anyone bought one of the USB Smartmedia readers that Olympus sells? Does this solve the problem of corrupting a functioning Smartmedia card? The OLYMPUS MAUSB-10 goes for under $20 on ebay even with shipping. Here is the basic question, will an OLYMPUS USB card reader corrupt a Smartmedia card that you want to use in a Olympus digital camera?

Unregistered guest
I have an Olympus C3000 Zoom and had three damaged Smartmedia cards, probably from trying them all in the camera one after the other when the battery was running down.

After many months of frustration trying SMPREP etc to no avail, here's how I resuscitated them:

With camera plugged in, Turn on camera.
When beep and flashing F appears, open the camera door, it goes to flashing 0 and message says door is open, move around between P and Playback and ASM settings, take out the card and put it back in with the door still open and it is still at flashing 0. Close the door. The error goes away. Go into Playback mode and Erase all the pictures rather than reformatting. I did all my experimenting with an 8MB card. Once I got that to work, I tried the same thing on my two 64MB cards, which were completely full of pictures. Eureka!!! Hope this helps somebody.

Unregistered guest
The OLYMPUS MAUSB-10 don't work. I buy it and nothing work , also my two SM card damaged don't recognize by the MAUSB but work perfectly in other reader !!

Unregistered guest
fabulous i saved my 2 corrupted card with a LDLC readerwriter 9in1 USB , smformat work fine !!!
And i format it with low level and the card works again !!!
Thxs for your support !!


Unregistered guest
Look, after a month solving this problem I fixed my 8Mb SmartMedia card using Low_Level_Format.exe.
When formatting it showed some errors but when I plugged the card to my Fujifilm camera it worked!
I put this utility to
Write me on if that helped you.

New member
Username: Roger69my

Post Number: 1
Registered: Mar-06
i had the same "card error" problem with my olympus sm card after accessing it with a card reader. i tried many methods to solve it but didn't work. i then tried to format it with my friend's fujifilm camera. it was successfully formated! i then put it back to my olympus camera and the "card error" was gone! to be on the safe side, i reformated it with my camera again. hope this would help you guys there with the same problem. good luck!

New member
Username: Scared

Post Number: 1
Registered: Apr-06
Help! I have a card error on my 64mb smartmedia card. I got it while taking pictures on my olympus camera and changing the pixel quality. I have never formated it or deleted pictures on my computer. Why did it do this? I need the pictures and am afraid I'll loose the pics when I format. The camera says to format and when I say ok it says it will erase all pictures. Is this right? It says card error on my HP printer. I took it to costco to try to print the pictures there and she said it had to be formatted to jpeg files. Will I loose the pics if I format? Please help!

New member
Username: Donziroc

Johnson City, TN Usa

Post Number: 1
Registered: Sep-06
I had "card error" on my 16meg card for my Olympus camera. I did the stupid thing and formatted it on my computer with windows XP. I searched hours. Try this. It worked for me on the very 1st attempt in windows XP with my HP computer that has the media reader built on the front panel.
DownLoad this program:

I ran this program in Windows XP Home, It found my 4 slot media reader. I clicked ok and it formatted my 16meg card. I put it in my camera and WOW! it worked!!!! I hope this helps

New member
Username: Jonmartin

United States

Post Number: 1
Registered: Oct-06
More on Low_Level_Format.exe

Available from or

The program is compatible with readers with these ID's.

For more on how to find your readers ID check here:

For a list of some readers with these IDs check here:

New member
Username: Jimfahrn

Austin, Texas

Post Number: 1
Registered: Feb-07
AWESOME! My Smart Media cards both work now on my Olympus C-3000z after following the TIPS from this Blog. I installed my OLD ZIO! SM card Reader and Ran the smprep.exe software provided originally and did a FULL Format of 16 MB SM card. I worked in Camera 1st time camera has worked at all for some time. And then I simply swapped my 128 MB Smart Media Card to the Camera and it also instantly was Recognized and Everything works!
I believe the trick of all suggestions was using a compatible Card Reader and the ZIO! USB Smart Reader seems to be the one. Don't know about all others but this one works GREAT now!
See ya soon on our Olympus Digital Camera trails...
Austin TX

New member
Username: Massgsm

Post Number: 1
Registered: Mar-07
I have had several SmartMedia cards die for no reason except that they gave up! I am not a techie so I found a UK repair service at and they all now work great even have the Olympus Pan working on them.

New member
Username: Curiousgeorge

Post Number: 1
Registered: Mar-07
Thanks for the link Geraldo. Anybody know if this problem with the cards dying happens with xD cards too? They are the same basic technology inside as the SmartMedia and even get reformatted the same. If you want to do the formatting yourself instead of mailing your cards off, check out the new OlyPan discussion forums at It is even easier than using SMprep now, and it works for xD cards too.

New member
Username: Sherrip


Post Number: 1
Registered: Jul-07
The is a great site. The problem is finding a card reader that will work with the programs. I tried bought and returned a few card readers but no success. I finally broke down and sent my card to a very nice gentleman at His prices were low and he provided some very useful tips on preventing the card errors.

New member
Username: Sde1

Post Number: 1
Registered: Sep-07
I followed the tip by Phyllis on my Olympus 3040 camera - put in smartmedia card, turn camera on, open door, put switch to P, playback, ASM, close door - magic! My corrupt smartmedia card is now fine!

New member
Username: Russianftp

Post Number: 2
Registered: Jan-11
The site can be found here now:
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message


Shop Related Deals


Main Forums

Today's Posts

Forum Help

Follow Us