Like

Sigma lens on D70 (20-40mmD)

 

New member
Username: Cyrus1

Post Number: 1
Registered: Nov-05
Hello,first post for myself;i've discovered image problems with my sigma lens this morning; (17/11/05).When i look through the viewfinder everything is dark and you can just make out an image of what you're looking at. Also on any mode it will not fire and struggles to focus from auto to manual.It was o.k. the last time i used it 2 days ago;i went out early (6ish) to get some frosty sunrise shots and the camera and lens produced terrible lens flare and grainy,dark images. I had to manually focus even when shooting at the sun.I feel really down about this at the moment as i know not what to do and this camera is my pride and joy: (digital photography being relatively new to me)and regard it as an answer to remain sane in this crazy world!! If anyone can help i'd more than appreciate it,thanks,wayne.I don't know whether the aperture is locked up or? If i take the lens off and look through at the aperture ring from the camera body end the ring appears closed on f32 region and when i try to manually open the aperture it doesn't open. Thanks.
 

Gold Member
Username: Project6

Post Number: 4259
Registered: Dec-03
Have you tried using another lens? This way you can narrow down the problem to either the lens or the camera body.
 

New member
Username: Cyrus1

Post Number: 2
Registered: Nov-05
Thanks Berny, yes, i've tried a 18-70 nikkor and 28-200 tamron no problems at all: this is why it appears to be the lens Berny-what shall i do? Also, i live in England -can i go to any camera shop or do i have to send it off to 'Sigma'inc.(The aperture appears to be 'locked up'do lower temperatures i.e. minus 5 affect these lenses i'm sure they shouldn't. (This was the temperature when it ceased working), Wayne.Any idea how much it'll cost to fix?
 

Gold Member
Username: Project6

Post Number: 4267
Registered: Dec-03
I'm terribly sorry to hear that. You are going to have to send it to the manufacturer for repair. Have you tried sending them an e-mail and inquiring about authorized repair centers?

But before anything, please check the contact points of the lenses, where the electronics make contact with the camera body. Ensure that they are clean and free of any grime. Reconnect the lens to the body and try again.

If that does not work, then it is time for repair.

I have not had any issues with my lenses when it gets cold.

 

New member
Username: Cyrus1

Post Number: 3
Registered: Nov-05
Thanks Berny-it's all spend,spend,spend these days! I appreciate your advice and i'll try and find a manufacturer/repair centre.Be in touch soon,Wayne.
 

Gold Member
Username: Project6

Post Number: 4645
Registered: Dec-03
How did the repair go, Wayne?
 

New member
Username: Jim1987

Post Number: 9
Registered: May-11
Its a cool lens dude.But if you are using 20mm-40mm lens then why not 12mm-35mm lens?
I always prefer 12 mm lens.
« Previous Thread | Next Thread »

Add Your Message Here

Bold text Italics Create a hyperlink Insert a clipart image Add a YouTube Video
Need to Register?
Forgot Password?
Enable HTML code in message
   

Facebook

Shop Related Deals

Directory

Main Forums

Today's Posts

Forum Help

Follow Us